Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
68 lines (62 sloc) 2.78 KB
name: yesod-auth
version: 1.0.2.1
license: MIT
license-file: LICENSE
author: Michael Snoyman, Patrick Brisbin
maintainer: Michael Snoyman <michael@snoyman.com>
synopsis: Authentication for Yesod.
category: Web, Yesod
stability: Stable
cabal-version: >= 1.6.0
build-type: Simple
homepage: http://www.yesodweb.com/
description: Authentication for Yesod.
flag blaze_html_0_5
description: use blaze-html 0.5 and blaze-markup 0.5
default: True
library
build-depends: base >= 4 && < 5
, authenticate >= 1.2.1 && < 1.3
, bytestring >= 0.9.1.4
, yesod-core >= 1.0 && < 1.1
, wai >= 1.2 && < 1.3
, template-haskell
, pureMD5 >= 2.0 && < 2.2
, random >= 1.0.0.2 && < 1.1
, text >= 0.7 && < 0.12
, mime-mail >= 0.3 && < 0.5
, yesod-persistent >= 1.0 && < 1.1
, hamlet >= 1.0 && < 1.1
, shakespeare-css >= 1.0 && < 1.1
, yesod-json >= 1.0 && < 1.1
, containers
, unordered-containers
, yesod-form >= 1.0 && < 1.1
, transformers >= 0.2.2 && < 0.4
, persistent >= 0.9 && < 0.10
, persistent-template >= 0.9 && < 0.10
, SHA >= 1.4.1.3 && < 1.6
, http-conduit >= 1.4.1.1 && < 1.5
, aeson >= 0.5
, pwstore-fast >= 2.2 && < 3
, lifted-base >= 0.1 && < 0.2
if flag(blaze_html_0_5)
build-depends:
blaze-html >= 0.5 && < 0.6
, blaze-markup >= 0.5.1 && < 0.6
else
build-depends:
blaze-html >= 0.4 && < 0.5
exposed-modules: Yesod.Auth
Yesod.Auth.BrowserId
Yesod.Auth.Dummy
Yesod.Auth.Email
Yesod.Auth.OpenId
Yesod.Auth.Rpxnow
Yesod.Auth.HashDB
Yesod.Auth.Message
Yesod.Auth.GoogleEmail
ghc-options: -Wall
source-repository head
type: git
location: https://github.com/yesodweb/yesod
Jump to Line
Something went wrong with that request. Please try again.