Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Use clientsession 0.9.* on Yesod 1.2. #520

Merged
merged 1 commit into from

2 participants

@meteficha
Owner

clientsession >= 0.9 uses skein == 1.0.* which includes Skein v1.3 up from Skein v1.1. I'm not sure if we should upgrade the clientsession dependency on Yesod 1.1 as well since that will break all current sessions on a stable branch of Yesod. Also, Yesod 1.2's release is already on the horizon. Therefore I didn't update the stable branch.

@snoyberg snoyberg merged commit 5d119bc into from
@snoyberg
Owner

Thanks! I released a new version in the 1.1 branch as well allowing the newer clientsession.

@meteficha
Owner

What I don't like about allowing clientsession >= 0.8 is that one may end up with binaries that can't be used together because they were compiled with different versions of clientsession. Things would get funny on a load balancer.

@snoyberg
Owner

I don't think the right way to address that problem is to make it impossible for users to use a newer version of the library if they want to. I think the only correct solution for production deployment is to nail down precise versions of all dependencies. I should really write a blog post on this topic, it's come up a few times.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Apr 1, 2013
  1. @meteficha
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  yesod-core/yesod-core.cabal
View
2  yesod-core/yesod-core.cabal
@@ -56,7 +56,7 @@ library
, shakespeare-i18n >= 1.0 && < 1.1
, blaze-builder >= 0.2.1.4 && < 0.4
, transformers >= 0.2.2 && < 0.4
- , clientsession >= 0.8 && < 0.9
+ , clientsession >= 0.9 && < 0.10
, random >= 1.0.0.2 && < 1.1
, cereal >= 0.3 && < 0.4
, old-locale >= 1.0.0.2 && < 1.1
Something went wrong with that request. Please try again.