Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Nodes and Edges are not produced for the extract_prism_data.R file #36

Open
pratikshrivastava opened this issue Nov 27, 2017 · 1 comment

Comments

2 participants
@pratikshrivastava
Copy link

commented Nov 27, 2017

Version: yw-1.0-alpha.6-win-x86-64.exe
OS: Windows 10, 64 bit.
Script: extract_prism_data.R

The yw generates the below graph for the above extract_prism_data.R file, without the nodes and the edges.

D:\Study\UIUC\MSIM\COURSES\FAll2017\Research Work\Testing_New_YW>yw-1.0-alpha.6-win-x86-64.exe graph Rscript\extract_prism_data.R
digraph extract_prism_data {

/* Start of box around nodes in workflow */
subgraph cluster_workflow_box_outer { label=""; color=black; penwidth=2
subgraph cluster_workflow_box_inner { label=""; penwidth=0

/* End of box around nodes in workflow */
}}
}
It generates a blank pdf file.
D:\Study\UIUC\MSIM\COURSES\FAll2017\Research Work\Testing_New_YW>yw-1.0-alpha.6-win-x86-64.exe graph Rscript\extract_prism_data.R | dot -Tpdf -o extract_prism_data.pdf
extract_prism_data.pdf

@tmcphillips

This comment has been minimized.

Copy link
Member

commented Nov 27, 2017

It looks like the problem is with the case where a YW model comprises a single program block representing the workflow as a whole, and there are no program blocks in the workflow. Is that right? I'll add this example as a test.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.