Skip to content
"Ask Me Anything" with Rails 5.2 Application
Branch: master
Clone or download
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.circleci Add database host Mar 14, 2019
app
bin rubocop --auto-correct Mar 14, 2019
config Upgrade webpacker 4 Mar 14, 2019
db Add fixtures for development Feb 16, 2018
lib
log rails new . -d postgresql -M -C -T -B --edge Feb 15, 2018
public
spec
tmp Add tmp/ Mar 14, 2019
vendor rails new . -d postgresql -M -C -T -B --edge Feb 15, 2018
.browserslistrc Upgrade webpacker 4 Mar 14, 2019
.dockerignore Refactor Dockerfile Mar 21, 2018
.env.sample
.gitignore Upgrade webpacker 4 Mar 14, 2019
.rspec
.rubocop.yml
Dockerfile Revert 2.6.2 => 2.6.1 Mar 14, 2019
Dockerfile.production
Gemfile Bump webpacker from 3.5.5 to 4.0.2 Mar 14, 2019
Gemfile.lock
LICENSE.txt
Makefile Refactor Dockerfile Mar 21, 2018
Procfile Configure Procfile for foreman Feb 15, 2018
README.md Revert 2.6.2 => 2.6.1 Mar 14, 2019
Rakefile
babel.config.js Upgrade webpacker 4 Mar 14, 2019
config.ru rubocop --auto-correct Feb 15, 2018
docker-compose.yml
package.json
postcss.config.js Upgrade webpacker 4 Mar 14, 2019
yarn.lock Bump eslint from 5.15.1 to 5.15.3 Mar 18, 2019

README.md

CircleCI Gitter chat

"Ask Me Anything" with Rails 5.2 Application.

This app's aim is to take questions and feedback from the audience.

Dependencies

  • Ruby 2.6.1
  • Ruby on Rails 5.2.2 (with Active Storage)
  • Yarn 1.13.0
  • Webpacker
  • Bootstrap 4
  • Stimulus 1.1.1
  • Postgresql 9.6.3
  • cmake

Getting started

on local

$ bin/setup
$ vim .env # for set GitHub auth key/secret. See: https://github.com/settings/developers
$ bin/rails s

on docker

$ docker-compose build
$ docker-compose run --rm app bin/setup
$ vim .env # for set GitHub auth key/secret. See: https://github.com/settings/developers
$ docker-compose up -d

License

MIT License

You can’t perform that action at this time.