Permalink
Browse files

(Fixes issue 2138) Updated required PHPUnit version

  • Loading branch information...
1 parent 271160c commit 9e328dedfc22684acff45b6ff8f628caf15ee9e0 alexander.makarow committed Feb 23, 2011
Showing with 3 additions and 11 deletions.
  1. +1 −1 docs/guide/test.overview.txt
  2. +1 −9 framework/test/CTestCase.php
  3. +1 −1 tests/readme.txt
@@ -27,7 +27,7 @@ Repeat step 1 to 5 to push forward the functionality implementation.
Test Environment Setup
----------------------
-The testing supported provided by Yii requires [PHPUnit](http://www.phpunit.de/) 3.4+ and [Selenium Remote Control](http://seleniumhq.org/projects/remote-control/) 1.0+. Please refer to their documentation on how to install PHPUnit and Selenium Remote Control.
+The testing supported provided by Yii requires [PHPUnit](http://www.phpunit.de/) 3.5+ and [Selenium Remote Control](http://seleniumhq.org/projects/remote-control/) 1.0+. Please refer to their documentation on how to install PHPUnit and Selenium Remote Control.
When we use the `yiic webapp` console command to create a new Yii application, it will generate the following files and directories for us to write and perform new tests:
@@ -9,15 +9,7 @@
*/
require_once('PHPUnit/Runner/Version.php');
-if(version_compare(PHPUnit_Runner_Version::id(), '3.5.0RC1')<0)
-{
- require_once('PHPUnit/Framework.php');
- require_once('PHPUnit/Framework/TestCase.php');
-}
-else
-{
- require_once('PHPUnit/Autoload.php');
-}
+require_once('PHPUnit/Autoload.php');
/**
* CTestCase is the base class for all test case classes.
View
@@ -1,5 +1,5 @@
This folder contains unit tests of Yii framework.
-PHPUnit 3.3+ and xdebug (for code coverage report) are required.
+PHPUnit 3.5+ and xdebug (for code coverage report) are required.
To run a single unit test, use:
>> phpunit path/to/test.php

0 comments on commit 9e328de

Please sign in to comment.