build command seems to require phpunit installed #963

Closed
cebe opened this Issue Jul 13, 2012 · 2 comments

Projects

None yet

3 participants

@cebe
Member
cebe commented Jul 13, 2012

https://github.com/yiisoft/yii/blob/master/build/build

not a good thing for translators, right?

@samdark
Member
samdark commented Jul 13, 2012

Yeah. Should not be mandatory.

@cebe
Member
cebe commented Jul 15, 2012

There are also problems with api command an phpunit autoloader.
created a pull request in phpunit on that and will create a pull request with workaround for yii soon. sebastianbergmann/phpunit#605

@cebe cebe added a commit to cebe/yii that referenced this issue Jul 15, 2012
@cebe cebe fixed PHPUnit autoloading
- removed requirement for PHPUnit from build command #963
- fixed PHPUnit autoloading in CTestCase
  register phpunit autoloader before Yii autoloader to handle phpunit
  autoloads correctly.
  Also require PHPUnit/Util/Filesystem.php to avoid Yii autoloader to
  crash initializing of PHPUnit autoloader, see also:
  sebastianbergmann/phpunit#605
  sebastianbergmann/phpunit#605
- imported CTestCase in CWebTestCase to ensure PHPUnit autoloader is
  initialized correctly
5cb7b35
@mdomba mdomba closed this Jul 25, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment