Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Crash when restarting Pulseaudio #45

Closed
pabloab opened this issue Feb 21, 2017 · 3 comments

Comments

@pabloab
Copy link

commented Feb 21, 2017

I was trying paprefs to output simultaneously when notice indicator-sound-switcher crash always I (kill and)restart Pulseaudio (pulseaudio -k).
Using v2.1.1, Ubuntu 16.04 and pulseaudio 8.0.

@yktoo

This comment has been minimized.

Copy link
Owner

commented Feb 21, 2017

Well yes, SSI doesn't account for PulseAudio dying while it's running. For me, it actually shows a critical error CRI Context failed. I'm not sure it's a problem really, obviously a sound switcher cannot function without the sound server. Perhaps exiting after PA has gone offline would be more consistent.

@pabloab

This comment has been minimized.

Copy link
Author

commented Feb 21, 2017

Maybe instead of crashing could handle/catch the situation, for example keep waiting to PA to come back (as usually happens after a pulseaudio -k). Also maybe could send a warning to notify-osd.

@yktoo

This comment has been minimized.

Copy link
Owner

commented Feb 23, 2017

I wholeheartedly agree that nothing should ever crash, but in my case there was no crash, just a log message with CRITICAL status. I'll think what can be done here.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.