Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updated usages of #provided? to #in_path?.

  • Loading branch information...
commit 1571423e9ecf2553f7db6461fd3d2127551dd902 1 parent f34d102
@benhoskings benhoskings authored
View
2  deps/git.rb
@@ -5,7 +5,7 @@
on :osx, 'git.installer'
otherwise 'git.managed'
}
- met? { provided? 'git >= 1.7' }
+ met? { in_path? 'git >= 1.7' }
end
dep 'git.managed' do
View
2  deps/ruby.rb
@@ -1,6 +1,6 @@
dep 'ruby' do
met? {
- provided? 'ruby >= 1.8.6'
+ in_path? 'ruby >= 1.8.6'
}
requires_when_unmet {
on :osx, 'ruby.external'
View
2  deps/rubygems.rb
@@ -18,7 +18,7 @@
dep 'rubygems installed' do
requires 'ruby'
requires_when_unmet 'curl.managed'
- met? { provided? %w[gem ruby] }
+ met? { in_path? %w[gem ruby] }
meet {
handle_source "http://production.cf.rubygems.org/rubygems/rubygems-1.3.7.tgz" do
shell "ruby setup.rb", :sudo => !File.writable?(which('ruby'))
View
2  deps/templates/external.rb
@@ -4,7 +4,7 @@
template {
met? {
- returning provided?(expects) || :fail do |result|
+ returning in_path?(expects) || :fail do |result|
otherwise.call if result == :fail
end
}
View
2  deps/templates/installer.rb
@@ -6,7 +6,7 @@
template {
prepare { setup_source_uris }
- met? { provided? }
+ met? { in_path? }
# At the moment, we just try to install every .[m]pkg in the archive.
# Example:
View
2  deps/templates/managed.rb
@@ -33,7 +33,7 @@ def add_cfg_deps
if installs.blank?
log_ok "Not required on #{pkg_manager.manager_key}-based systems."
else
- packages_present? and provided?
+ packages_present? and in_path?
end
}
before {
Please sign in to comment.
Something went wrong with that request. Please try again.