This is a COPY of Issue 25: GoDaddy Htaccess Problem / Fix, filed on Google Code before the project was moved on Github.
Please review the original issue and especially its comments. Comments here on closed issues will be ignored. Thanks.
Original description
While using GoDaddy to host YOURLS, I received a 404 error for all short URLs.
Changed this line of htaccess:
RewriteRule ^([0-9A-Za-z]+)/?$ yourls-go.php?id=$1 [L]
to:
RewriteRule ^([0-9A-Za-z]+)/?$ /yourls-go.php?id=$1 [L]
And short URLs work. My thanks to Max Leadford on the WarriorForums.
Submitted here for posterity.
This is a COPY of Issue 25: GoDaddy Htaccess Problem / Fix, filed on Google Code before the project was moved on Github.
Please review the original issue and especially its comments. Comments here on closed issues will be ignored. Thanks.
Original description