Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Why the dependency on jshint at version ~1.1.0? #5

Closed
wants to merge 1 commit into from

5 participants

@matthew-andrews

JSHint is now at version 2.1.4 so any module that depends on it without specifying a ~1.1.0 version, this library now break - NPM can't resolve the dependency.

Example: https://github.com/gotwarlost/istanbul-middleware

Steps to reproduce:

git clone https://github.com/gotwarlost/istanbul-middleware
cd istanbul-middleware
npm install

Observe the following error:

npm WARN unmet dependency /Users/matthew/Documents/sandboxes/istanbul-middleware/node_modules/yui-lint requires jshint@'~1.1.0' but will load
npm WARN unmet dependency /Users/matthew/Documents/sandboxes/istanbul-middleware/node_modules/jshint,
npm WARN unmet dependency which is version 2.1.4

(I also updated the README.md to this version of jshint as I suspect anyone copying & pasting the sample into their package.json would also run into this problem).

@matthew-andrews

Think the failure to resolve was only with old versions of NPM. The current version of NPM was able to resolve just fine. It would still be nice to update the version of jshint being used though?

@reid

@yui/yui-3-reviewers I plan to upgrade the YUI linter to use JSHint 2.x. I'll make every effort to make sure rules are kept intact, but we should anticipate some lint changes with the new version.

YUI Lint depends on JSHint 1.1.0, which depends on Esprima hosted on GitHub.com. This means that our CI system depends on GitHub.com's web service — when GitHub goes down, we can't run YUI builds. This dependency was removed in 2.0.0.

Check out the JSHint changes from 1.1.0 to 2.0.0. I'll plan on upgrading to the JSHint 2.3.0 if possible.

@reid reid was assigned
@okuryu okuryu commented on the diff
package.json
@@ -4,7 +4,7 @@
"version": "0.1.3",
"main": "./yui-lint.js",
"dependencies": {
- "jshint": "~1.1.0"
+ "jshint": "~2.1.0"
@okuryu
okuryu added a note

I think yui-lint shouldn't need to depend on jshint. It would be better to move out of dependencies.

@ericf Owner
ericf added a note

Agreed!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@okuryu

Any update on this?

@akshayp

Any updates here? 50/75 megs packaged with shifter are because yui-lint relies on a very old version of jslint. It'll greatly improve install times for folks relying on shifter in CI systems.

//cc @redonkulus

@ericf
Owner

I think we should kill this project. JSHint has a "YUI" option.

@ericf
Owner

Closing this in favor of #7

@ericf ericf closed this
@reid reid was unassigned by jlecomte
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jul 19, 2013
  1. @matthew-andrews
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 2 deletions.
  1. +1 −1  README.md
  2. +1 −1  package.json
View
2  README.md
@@ -69,7 +69,7 @@ From inside your package.json:
{
"devDependencies": {
- "jshint": "~0.9.0",
+ "jshint": "~2.1.0",
"yui-lint": "~0.1.1"
},
"scripts": {
View
2  package.json
@@ -4,7 +4,7 @@
"version": "0.1.3",
"main": "./yui-lint.js",
"dependencies": {
- "jshint": "~1.1.0"
+ "jshint": "~2.1.0"
@okuryu
okuryu added a note

I think yui-lint shouldn't need to depend on jshint. It would be better to move out of dependencies.

@ericf Owner
ericf added a note

Agreed!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
},
"scripts": {
"test": "jshint --config ./jshint.json ./*.js ./*.json"
Something went wrong with that request. Please try again.