New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Complete local build instructions (new problems) #2005

Open
kostjerry opened this Issue Jan 16, 2017 · 5 comments

Comments

Projects
None yet
4 participants
@kostjerry

kostjerry commented Jan 16, 2017

Referencing #916

Hi!

  1. I noticed that before grunt release you must also run
npm i shifter
  1. Is there any way to automatically (thru args) setup BASE url in the build?

  2. I have run grunt release and got an error:

Running "npm-copy" task
Copying to build dir: /usr/local/www/static/vendor/yui3/build-npm
**Fatal error: Path must be a string. Received undefined**

Did the instructions change since 2013?

Thanks!

@A-sen

This comment has been minimized.

Show comment
Hide comment
@A-sen

A-sen commented Jan 18, 2017

????

@kostjerry

This comment has been minimized.

Show comment
Hide comment
@kostjerry

kostjerry Jan 18, 2017

My purpose is to build YUI manually for my own CDN over HTTPS.

Here is the tutorial that seems to be broken:
https://github.com/yui/yui3/wiki/Developer-Workflow#building-yui

kostjerry commented Jan 18, 2017

My purpose is to build YUI manually for my own CDN over HTTPS.

Here is the tutorial that seems to be broken:
https://github.com/yui/yui3/wiki/Developer-Workflow#building-yui

@redonkulus

This comment has been minimized.

Show comment
Hide comment
@redonkulus

redonkulus Jan 18, 2017

Contributor

It's probably cause of changes in node since those libraries were created. You have two options, try to fix those errors locally to get it to work. Or just down grade to node 0.10 and try running it again.

Contributor

redonkulus commented Jan 18, 2017

It's probably cause of changes in node since those libraries were created. You have two options, try to fix those errors locally to get it to work. Or just down grade to node 0.10 and try running it again.

@kostjerry

This comment has been minimized.

Show comment
Hide comment
@kostjerry

kostjerry Jan 18, 2017

ok, thanks!

kostjerry commented Jan 18, 2017

ok, thanks!

@clarle

This comment has been minimized.

Show comment
Hide comment
@clarle

clarle Mar 21, 2017

Contributor

I was able to build YUI 3.16.2-pre using Node v6.9.5 and npm v3.10.10.

You don't necessarily need to run grunt release to build YUI.

You can just install Shifter and then run shifter --walk in the src directory. It'll create all of the files you need to put on your CDN in the build directory.

Contributor

clarle commented Mar 21, 2017

I was able to build YUI 3.16.2-pre using Node v6.9.5 and npm v3.10.10.

You don't necessarily need to run grunt release to build YUI.

You can just install Shifter and then run shifter --walk in the src directory. It'll create all of the files you need to put on your CDN in the build directory.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment