Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Gem requires 2.3.0dev ? #61

Closed
tleish opened this issue Dec 25, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@tleish
Copy link

commented Dec 25, 2015

In trying to upgrade to the latest, I'm given the warning that it requires 2.3.0dev (currently running ruby 2.1.5). Is this correct?

 $ gem update did_you_mean                                                                                                                                     22:57:42
Updating installed gems
Updating did_you_mean
ERROR:  Error installing did_you_mean:
    did_you_mean requires Ruby version >= 2.3.0dev.

Is this correct? gemspec and rubygems.org both indicate:

REQUIRED RUBY VERSION:
>= 1.9.3

Note: I just upgraded my OSX, so this could be an un-related issue.

@yuki24

This comment has been minimized.

Copy link
Owner

commented Dec 26, 2015

@tleish That is correct. The required ruby version (2.3.0dev) looks incorrect but is also correct. The version 1.0.0 has been released exclusively for Ruby 2.3 and doesn't work on any older Ruby versions. I'm not going to talk about the circumstances here, but please use 0.10.0 if you use Ruby 2.2 or older.

@yuki24 yuki24 closed this Dec 26, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.