New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix compatibility with fluentd 0.14.x #31

Merged
merged 1 commit into from Mar 22, 2017

Conversation

Projects
None yet
2 participants
@a-know

a-know commented Mar 22, 2017

Getting this error with fluentd v0.14.13.

unexpected error error_class=NameError error="uninitialized constant Fluent::Input"
/opt/td-agent/embedded/lib/ruby/gems/2.1.0/gems/fluent-plugin-cloudwatch-1.2.15/lib/fluent/plugin/in_cloudwatch.rb:1:in `<top (required)>'

According to repeatedly/fluent-plugin-beats#1 , it seems to need require 'fluent/input' statement.

@fujiwara fujiwara merged commit 0bb9c15 into yunomu:master Mar 22, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@fujiwara

This comment has been minimized.

Show comment
Hide comment
@fujiwara

fujiwara Mar 22, 2017

Collaborator

Thanks !

But I found an another problem with fluentd v0.14.13.

#0 Unable to activate aws-sdk-v1-1.66.0, because json-2.0.3 conflicts with json (> 1.4) path=nil error_class=Gem::ConflictError error="Unable to activate aws-sdk-v1-1.66.0, because json-2.0.3 conflicts with json (> 1.4)"

I will fix it and release. Please wait for a while.

Collaborator

fujiwara commented Mar 22, 2017

Thanks !

But I found an another problem with fluentd v0.14.13.

#0 Unable to activate aws-sdk-v1-1.66.0, because json-2.0.3 conflicts with json (> 1.4) path=nil error_class=Gem::ConflictError error="Unable to activate aws-sdk-v1-1.66.0, because json-2.0.3 conflicts with json (> 1.4)"

I will fix it and release. Please wait for a while.

@fujiwara

This comment has been minimized.

Show comment
Hide comment
@fujiwara
Collaborator

fujiwara commented Mar 23, 2017

v2.0.0 (using aws-sdk v2) released.
https://rubygems.org/gems/fluent-plugin-cloudwatch/versions/2.0.0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment