Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ユーザ領域にgemがインストールされている環境でクラッシュする? #1

Open
toshia opened this issue Mar 3, 2018 · 0 comments

Comments

@toshia
Copy link

@toshia toshia commented Mar 3, 2018

実行後、UIなどが表示される前にクラッシュします。バックトレースだけ見ている感じだと起動中っぽいですね。

$HOME/.gem/ 以下のユーザ領域にインストールしているgemを全て削除すると起動できるようになりました。ホストはRuby 2.5で、ユーザ領域に入っているgemは2.4のものが残ってて、何故かそれを参照することがあるんですかね。

/tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': libruby.so.2.4: cannot open shared object file: No such file or directory - /home/toshi/.gem/ruby/2.4.0/gems/psych-2.2.4/lib/psych.so (LoadError)
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /home/toshi/.gem/ruby/2.4.0/gems/psych-2.2.4/lib/psych.rb:8:in `<top (required)>'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/yaml.rb:6:in `<top (required)>'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/configloader.rb:13:in `<top (required)>'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:95:in `file_or_directory_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `each'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:18:in `miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/plugin.rb:4:in `<top (required)>'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:93:in `file_or_directory_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `each'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:18:in `miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire_plugin.rb:2:in `<top (required)>'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:95:in `file_or_directory_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `each'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:18:in `miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/boot/load_plugin.rb:3:in `<top (required)>'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:98:in `miquire_original_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:95:in `file_or_directory_require'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:76:in `block in miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `each'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:75:in `miquire'
        from /tmp/.mount_mikutt2jjtM2/usr/share/mikutter/core/miquire.rb:18:in `miquire'
        from share/mikutter/mikutter.rb:42:in `<main>'

yuntan pushed a commit that referenced this issue Jun 26, 2019
プラグインの依存関係に記述すべきものを書いた
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.