Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem with .htaccess PulseCMS version 5.3.9 #137

Closed
bigbossie opened this issue Jan 5, 2020 · 11 comments
Closed

Problem with .htaccess PulseCMS version 5.3.9 #137

bigbossie opened this issue Jan 5, 2020 · 11 comments

Comments

@bigbossie
Copy link

@bigbossie bigbossie commented Jan 5, 2020

When I copy the PulseCMS 5.3.9 file to the host server and then do the install with [websitename]/admin/install.php I get the notification that "This page is not working", {website} has redirected too many times, try to delete your cookies, ERR_TOO_MANY_REDIRECTS. Whatever I try, delete my cookies , nothing works. The message keeps the same.
I made a ticket to my hostprovider and they came back that the lines"

ensure HTTPS - comment out lines 10 and 11 if installing locally without an SSL certificate

RewriteCond %{HTTPS} off
RewriteRule ^/?(.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

are not necessary, because the forcing of HTTPS is already done by there system of the Hosting Provider.

The .htaccess file contains:

Uncomment line 2 and 3 below if uploading issues via Media or Dropzone

php_value upload_max_filesize 20M

php_value post_max_size 25M

RewriteEngine On

RewriteBase /

ensure HTTPS - comment out lines 10 and 11 if installing locally without an SSL certificate

RewriteCond %{HTTPS} off
RewriteRule ^/?(.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

draft blog pages

RewriteRule ^blog-draft-([^-]*)? "index.php?p=blog-draft-$1" [L,QSA]

RewriteRule ^tagged/(.*)$ ?p=blog&blog_tag_name=$1 [L,QSA]

RewriteRule ^blog-page-([^-])$ ?page=$1&p=blog [L,QSA]
RewriteRule ^blog-([^-]
)+? ?d=$1&p=blog [L,QSA]

end points for embedding into non-Pulse sites

RewriteRule ^endpoint/(.*)$ end_point.php?item=$1 [L,QSA]

drop zone upload handler

RewriteRule ^dropzone_upload_handler.php$ dropzone_upload_handler.php [L,QSA]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?p=$1 [QSA,L]

Adds SVG image support

AddType image/svg+xml svg svgz
AddEncoding gzip svgz

add audio/video support

AddType video/mpg .mpg
AddType video/ogg .ogv
AddType video/mp4 .mp4
AddType video/webm .webm

AddType audio/mpeg .mp3
AddType audio/ogg .ogg
AddType audio/mp4 .m4a
AddType audio/wav .wav

block directory listing

Options -Indexes

After deleting the "# ensure HTTPS..................................", I get the error message HTTP ERROR 500.

What is wrong here? Do I something wrong? I only have copied the PulseCMS files to the server and I can't install it because of this. Please help?

With Regards,

Jeroen Kotterlink

@yuzoolcode

This comment has been minimized.

Copy link
Owner

@yuzoolcode yuzoolcode commented Jan 18, 2020

Thanks, you can delete lines 10 and 11

But does your host provide an SSL certificate?

@yuzoolcode

This comment has been minimized.

Copy link
Owner

@yuzoolcode yuzoolcode commented Jan 18, 2020

CleanShot 2020-01-18 at 10 52 11

For example on localhost I don't have SSL installed and uncommented those lines added a "#" and ran the installer and it worked fine

If you are getting a HTTP ERROR 500 then something else is wrong on the server

@bigbossie

This comment has been minimized.

Copy link
Author

@bigbossie bigbossie commented Jan 19, 2020

Hello,

I deleted the lines 10, 11 and SSL certificate is installed. I ran the test and everything seems OK. (See printscreen)

I don't know what I can do now.
Is there specific information I need from my provider why this isn't working?
With regards, Jeroen

reqs

@yuzoolcode

This comment has been minimized.

Copy link
Owner

@yuzoolcode yuzoolcode commented Jan 20, 2020

  • can you share a link?
  • where are you hosting (what provider?)
  • what are they saying about the site?
@yuzoolcode

This comment has been minimized.

@bigbossie

This comment has been minimized.

Copy link
Author

@bigbossie bigbossie commented Jan 27, 2020

@yuzoolcode

This comment has been minimized.

Copy link
Owner

@yuzoolcode yuzoolcode commented Jan 29, 2020

Thanks

Seems we are talking here also:
https://forum.pulsecms.com/t/problem-with-pulsecms-5-3-9-err-too-many-redirects/1791/10

Can you attach your site logs?
(go to Debug from Admin drop down and upload them to here or the forum post)

Thanks

@bigbossie

This comment has been minimized.

Copy link
Author

@bigbossie bigbossie commented Jan 29, 2020

Hereby the log files from the site/server.

Archive logs.zip

@yuzoolcode

This comment has been minimized.

Copy link
Owner

@yuzoolcode yuzoolcode commented Jan 31, 2020

These are the general web server logs and not the pulsecms ones.

Can you get the logs from the pulse admin under settings and "debug" or from the server Pulse install under pulsecore/storage/logs

Thanks

@bigbossie

This comment has been minimized.

Copy link
Author

@bigbossie bigbossie commented Feb 1, 2020

@yuzoolcode yuzoolcode closed this Feb 15, 2020
@bigbossie

This comment has been minimized.

Copy link
Author

@bigbossie bigbossie commented Feb 15, 2020

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.