pyalgotrade working on python 3
Switch branches/tags
Nothing to show
Clone or download
Pull request Compare This branch is even with manabuo:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
__pycache__
barfeed
bitcoincharts
bitstamp
broker
dataseries
feed
optimizer
stratanalyzer
strategy
talibext
technical
tools
twitter
utils
websocket
README.md
__init__.py
bar.py
dispatcher.py
dispatchprio.py
eventprofiler.py
logger.py
marketsession.py
observer.py
plotter.py
resamplebase.py
warninghelpers.py

README.md

pyalgotrade-python-3

pyalgotrade working on python 3 PyAlgoTrade is an event driven algorithmic trading Python library. The initial focus was on backtesting, paper trading Bitcoins, shares. However, the current version can only run under python 2, thus it cannot enjoy many new features of python 3.

After debugging the original scripts, I successfully run them under python 3. 6.

Installation

PyAlgoTrade is developed using Python 3.6 and depends on: NumPy and SciPy. pytz. dateutil. requests. matplotlib for plotting support. ws4py for Bitstamp support. tornado for Bitstamp support. tweepy for Twitter support.

This will downgrade the pyalgotrade: pip install pyalgotrade

clone or download this pyalgotrade-python-3, copy all the files and folds under pyalgotrade-python-3 to override existing pyalgotrade.

Full document can be found here: http://gbeced.github.io/pyalgotrade/docs/v0.18/html/index.html