Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fix travis testing #4

Merged
merged 1 commit into from

2 participants

@carsonmcdonald

Added a scheme for NSStringRubyTests and updated the travis config.

@zdavison
Owner

Sound!

@zdavison zdavison merged commit 6251aad into zdavison:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 6, 2013
  1. @carsonmcdonald

    Fix travis testing

    carsonmcdonald authored
This page is out of date. Refresh to see the latest.
View
9 .travis.yml
@@ -1,3 +1,8 @@
language: objective-c
-
-script: xctool -project NSString+Ruby.xcworkspace -scheme "NSStringRuby" build test -sdk iphonesimulator -arch i386
+before_install:
+ - gem install cocoapods --no-rdoc --no-ri --no-document --quiet
+ - brew update
+ - brew uninstall xctool
+ - brew install xctool --HEAD
+ - pod install
+script: xctool -workspace NSString+Ruby.xcworkspace -scheme "NSStringRubyTests" test -sdk iphonesimulator -arch i386
View
53 NSString+Ruby.xcodeproj/xcshareddata/xcschemes/NSStringRubyTests.xcscheme
@@ -0,0 +1,53 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<Scheme
+ LastUpgradeVersion = "0500"
+ version = "1.3">
+ <BuildAction
+ parallelizeBuildables = "YES"
+ buildImplicitDependencies = "YES">
+ </BuildAction>
+ <TestAction
+ selectedDebuggerIdentifier = "Xcode.DebuggerFoundation.Debugger.LLDB"
+ selectedLauncherIdentifier = "Xcode.DebuggerFoundation.Launcher.LLDB"
+ shouldUseLaunchSchemeArgsEnv = "YES"
+ buildConfiguration = "Debug">
+ <Testables>
+ <TestableReference
+ skipped = "NO">
+ <BuildableReference
+ BuildableIdentifier = "primary"
+ BlueprintIdentifier = "873D10F41804A51700BCAC49"
+ BuildableName = "NSStringRubyTests.xctest"
+ BlueprintName = "NSStringRubyTests"
+ ReferencedContainer = "container:NSString+Ruby.xcodeproj">
+ </BuildableReference>
+ </TestableReference>
+ </Testables>
+ </TestAction>
+ <LaunchAction
+ selectedDebuggerIdentifier = "Xcode.DebuggerFoundation.Debugger.LLDB"
+ selectedLauncherIdentifier = "Xcode.DebuggerFoundation.Launcher.LLDB"
+ launchStyle = "0"
+ useCustomWorkingDirectory = "NO"
+ buildConfiguration = "Debug"
+ ignoresPersistentStateOnLaunch = "NO"
+ debugDocumentVersioning = "YES"
+ allowLocationSimulation = "YES">
+ <AdditionalOptions>
+ </AdditionalOptions>
+ </LaunchAction>
+ <ProfileAction
+ shouldUseLaunchSchemeArgsEnv = "YES"
+ savedToolIdentifier = ""
+ useCustomWorkingDirectory = "NO"
+ buildConfiguration = "Release"
+ debugDocumentVersioning = "YES">
+ </ProfileAction>
+ <AnalyzeAction
+ buildConfiguration = "Debug">
+ </AnalyzeAction>
+ <ArchiveAction
+ buildConfiguration = "Release"
+ revealArchiveInOrganizer = "YES">
+ </ArchiveAction>
+</Scheme>
Something went wrong with that request. Please try again.