Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Sep 27, 2010
  1. Version bump to 0.2.0

    authored
  2. Updated how activerecord-import loads so it is done after a connectio…

    authored
    …n is established in ActiveRecord. This supports loading import for multiple adapters automatically w/o having to have a person require those specifically.
  3. Updating Gemfile to require jeweler and rakefile to use Bundler to en…

    authored
    …sure dependencies are installed.
Commits on Sep 26, 2010
  1. Deprecating usage of "require 'activerecord-import/<adapter_name>'" i…

    authored
    …n favor of "require 'activerecord-import'".
  2. Refactoring to allow for separation of activerecord-import code and a…

    authored
    …ctiverecord's connection adapters.
Commits on Aug 21, 2010
Commits on Aug 11, 2010
  1. Bump version to 0.1.0.

    authored
  2. Updating README

    authored
  3. @pwnall

    Initial work for re-packaging as gem.

    pwnall authored committed
  4. Updated how tests are run so Rake is not invoked twice.

    authored
    * removing support for Oracle in the rakefile as it is no currently supported
  5. Moved all adapter specific code into adapters/ directory and updated …

    authored
    …all adapters to utilize the same "require_adapter" method of loading specific-database adapters.
    
    * Adds back in SQLite3 and PostgreSQL support
    
    issue-url: http://github.com/zdennis/activerecord-import/issues#issue/1 
    [contributes #1]
Commits on Jun 26, 2010
  1. Restructuring directories.

    authored
Commits on Apr 9, 2010
  1. Added back in basic benchmark support. To run:

    authored
      ruby benchmark/benchmark.rb --adapter mysql --num 1000
      ruby benchmark/benchmark.rb --adapter mysql --num 1000 --to-csv /tmp/results.csv
      ruby benchmark/benchmark.rb --adapter mysql --num 1000 --to-html /tmp/results.html
  2. Adding a README file.

    authored
  3. * Added basic import support for PostgreSQL.

    authored
    * Requiring database adapter is now "require 'ar-extensions/import/<adapter_name>" so it won't conflict with previous versions of ar-extensions or other libraries extracted out of older ar-extensions, which "require 'ar-extensions'"
Commits on Mar 14, 2010
  1. Finished porting over MySQL import functionality.

    authored
    * removed assertions on #num_inserts, that is db-specific and is handled in details by abstract_adapter_test.
  2. Minor refactoring.

    authored
Commits on Mar 12, 2010
Something went wrong with that request. Please try again.