Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Commits on Jan 20, 2012
  1. Version bump to 0.2.9

  2. Merge pull request #43 from duckpond/c9a4313f8ba5805bfcca314a5b93d472…

    Active record dependency does not work with rails 3.2
  3. remove dependency on activerecord 3.0

    Samantha John authored
Commits on Jan 6, 2012
  1. Merge pull request #20 from Empact/drop_sum_sizes

    Rely on ActiveSupport #sum rather than #sum_sizes
Commits on Jan 3, 2012
  1. Merge pull request #38 from wycats/module_cleanup

    Clean up module usage.
  2. @wycats

    Clean up module usage. There's no need to use InstanceMethods -- norm…

    wycats authored
    …al Ruby modules and includes will work fine here.
Commits on Dec 14, 2011
  1. Merge pull request #33 from nbudin/master

    Use connection pool instead of actual connection on load (helps with Rails 3.1 on Heroku)
Commits on Oct 10, 2011
  1. @nbudin

    Use connection pool instead of actual connection to avoid having to c…

    nbudin authored
    …onnect to the database until necessary
Commits on Aug 17, 2011
  1. @Empact

    Replace #sum_sizes with calls to ActiveSupport #sum, as splatting lar…

    Empact authored
    …ge numbers of values is resource intensive andcan cause stack overflows of the sort 'SystemStackError: stack level too deep'
Commits on Aug 14, 2011
  1. Bumping to 0.2.8

Commits on Jul 13, 2011
  1. Bumping VERSION to 0.2.8.rc3

  2. Merge pull request #27 from msgehard/fix_gemfile

    Relax pg version dependency a bit.
  3. @mikegehard

    Relax pg version dependency a bit. The Gemfile specifies pg ~>0.9.0 a…

    mikegehard authored
    …nd Rails 3.1 specifies pg 0.11 so there is no way for bundler to install pg for a new download.
Commits on Jun 23, 2011
  1. Bumping VERSION to 0.2.8.rc2

  2. Merge pull request #21 from jamiecobbett/master

    Fix import of very large datasets containing multibyte chars on Ruby 1.9
  3. Merge pull request #26 from fallwith/master

    Ruby 1.9.2 / RubyGems 1.8.5 compatibility fix (pass String instead of Pathname to require)
Commits on Jun 22, 2011
  1. @fallwith

    Regexp.escape which is called by Gem.loaded_path? (/usr/local/lib/rub…

    fallwith authored
    …y/site_ruby/1.9.1/rubygems.rb) expects the path as a String, not a Pathname. Convert Pathnames to Strings prior to calling 'require'
Commits on May 8, 2011
  1. Correctly obey MySQL MAX PACKET

    Jamie Cobbett authored
    Use String's bytesize instead of size, because we're talking about byte length,
    not string length. This resolves a problem on Ruby 1.9 with multi-byte
Commits on May 5, 2011
  1. Adding jdbcmysql support.

    Jason authored committed
Commits on May 4, 2011
  1. Updating import_test to be Ruby 1.9.2 compatible. Ruby 1.9.1 changed …

    …the Date.parse capabilities to no longer support MM/DD/YYYY functionality so we only test against YYYY/MM/DD.
    [fixes #19]
Commits on Apr 29, 2011
  1. Version bump to 0.2.7

  2. Do not use when instantiating AR models. …

    …Use form of instantiation that allows protected attributes to be set.
Commits on Apr 6, 2011
  1. Version bump to 0.2.6

  2. Version bump to 0.3.0

  3. Added :synchronize_keys to the import options so importing can synchr…

    …onize on fields beside the primary key.
Commits on Mar 19, 2011
  1. Adding in support for :synchronization option for #import. Pulled in …

    …from ar-extensions. Currently only works with MySQL since that is the only database that supports on duplicate key update functionality.
  2. Turning off warnings because FactoryGirl spews out crap and it makes …

    …it impossible to see anything useful.
Something went wrong with that request. Please try again.