Hyper.app does not load zsh correctly on 1.0.0, did before (errors in devtools) #1131

Closed
Connorelsea opened this Issue Dec 12, 2016 · 2 comments

Projects

None yet

2 participants

@Connorelsea
Connorelsea commented Dec 12, 2016 edited
  • I am on the latest Hyper.app version
  • I have searched the issues of this repo and believe that this is not a duplicate

Issue

Hyper.app does not load zsh correctly on 1.0.0, did before.

This is how iTerm 2 opens. Using my zsh configuration. Hyper.app opened like this before version 1.0.0.

image

This is how the terminal opens using Hyper.app, seemingly not using zsh.

image

Here is the devtools output:

image

This happens if I type stuff:

image

@Connorelsea

Update:

It seems as if this is loading zsh, but is not loading it correctly. I wonder why my two terminals look differently.

image

@dotcypress dotcypress added a commit to dotcypress/hyper that referenced this issue Dec 12, 2016
@dotcypress dotcypress fixes #1131 c2540d9
@dotcypress
Contributor
dotcypress commented Dec 12, 2016 edited

Fixed in #1111
Stay tuned 😉

@dotcypress dotcypress added a commit to dotcypress/hyper that referenced this issue Dec 13, 2016
@dotcypress dotcypress fixes #1131 d03668a
@rauchg rauchg added a commit that closed this issue Dec 14, 2016
@dotcypress @rauchg dotcypress + rauchg 🚀 Performance tuning & bugfix (#1111)
* Perfomance tuning

* cleanup matchesContainer method

* fixes #1131
d6316dd
@rauchg rauchg closed this in d6316dd Dec 14, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment