New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Prompt doesn't appear when opening new horizontal panes (and I think I know why) #3258

Open
nickjj opened this Issue Oct 18, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@nickjj

nickjj commented Oct 18, 2018

Issue

Every time I open new horizontal pane, I have an empty prompt. I just started using hyper.js so I don't know if this happens with other actions.

I can get the prompt to come back by pressing either CTRL+C or Enter multiple times.

If I split 1 horizontal pane It takes 20 times of pressing Enter or CTRL+C before the prompt is visible and this number seems to go up as I add more horizontal panes. It seems to always go by about 2 additional key presses required for each pane I open.

I believe the prompt is always there because if I type ls -la I see the bottom end of the output and the prompt returns. If I had to guess it's not placed at the new pane's visual location, it's hidden behind the other panes at the top. If I open a vertical pane with no horizontal panes the prompt shows immediately at the top, which really leads me to think the prompt always loads at the top of the window?

Edit: I also want to add after opening and closing a bunch of panes the prompt doesn't always become visible, even if you expect it to be at the top. I'm not sure where it ends up, but it's not there (although the same strategy mentioned above to get it back works).

@nickjj

This comment has been minimized.

nickjj commented Dec 8, 2018

This still happens with canary 3.

@dontsave

This comment has been minimized.

dontsave commented Dec 13, 2018

This just started happening to me after upgrading to win 1809. It was working fine before the update. It happens with both vertical and horizontal panes. Using WSL/Ubuntu. I can run multiple instances of hyper, but not multiple hyper panes

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment