Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

`now` is giving an error using Mojave and Node 8 LTS #2711

Closed
paulogdm opened this issue Aug 6, 2019 · 2 comments

Comments

@paulogdm
Copy link
Member

commented Aug 6, 2019

$ now
(node:32756) ExperimentalWarning: The http2 module is an experimental API.
(node:32756) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 nowExit listeners added. Use emitter.setMaxListeners() to increase limit
> Error! An unexpected error occurred!
TypeError: e.ref is not a function
at f.ref (/usr/local/lib/node_modules/now/dist/index.js:2:491203)
at H2Context.getOrCreateHttp2 (/usr/local/lib/node_modules/now/dist/index.js:2:488764)
at Context.getOrCreateHttp2 (/usr/local/lib/node_modules/now/dist/index.js:2:1713162)
at Context.getHttp2 (/usr/local/lib/node_modules/now/dist/index.js:2:1713387)
at Object.get (/usr/local/lib/node_modules/now/dist/index.js:2:1711928)
at fetchImpl (/usr/local/lib/node_modules/now/dist/index.js:2:3785448)
at <anonymous> TypeError: e.ref is not a function
at f.ref (/usr/local/lib/node_modules/now/dist/index.js:2:491203)
at H2Context.getOrCreateHttp2 (/usr/local/lib/node_modules/now/dist/index.js:2:488764)
at Context.getOrCreateHttp2 (/usr/local/lib/node_modules/now/dist/index.js:2:1713162)
at Context.getHttp2 (/usr/local/lib/node_modules/now/dist/index.js:2:1713387)
at Object.get (/usr/local/lib/node_modules/now/dist/index.js:2:1711928)
at fetchImpl (/usr/local/lib/node_modules/now/dist/index.js:2:3785448)
at <anonymous>

The error was originally reported by @leourbina.

node version is v8.9.0
now version is 16.0.0
@TooTallNate

This comment has been minimized.

Copy link
Member

commented Aug 6, 2019

Because of fetch-h2, you need node >= 8.11.

We should do one of the following:

  • Adjust the engines field in package.json to require node >= 8.11, or
  • Not use fetch-h2 in < 8.10
@leo

This comment has been minimized.

Copy link
Member

commented Aug 6, 2019

Engines field!

TooTallNate added a commit that referenced this issue Aug 6, 2019

TooTallNate added a commit that referenced this issue Aug 6, 2019

AndyBitz added a commit that referenced this issue Aug 7, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.