Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[examples] Update jekyll and middleman to use bundler 2.1.4 #3923

Merged
merged 3 commits into from Mar 17, 2020
Merged

Conversation

@styfle
Copy link
Member

styfle commented Mar 17, 2020

These examples were using an old version of Bundler which didn't match our tests and would fail with:

/ruby27/lib/ruby/2.7.0/rubygems.rb:275:in `find_spec_for_exe': Could not find 'bundler' (1.17.2) required by your /zeit/6f4b9e46/Gemfile.lock. (Gem::GemNotFoundException)
To update to the latest version installed on your system, run `bundle update --bundler`.
To install the missing version, run `gem install bundler:1.17.2`
	from /ruby27/lib/ruby/2.7.0/rubygems.rb:294:in `activate_bin_path'
	from /ruby27/bin/bundle:23:in `<main>'

I ran bundle update --bundler in each of these directories and it only updated the version in Gemfile.lock because 2.x is mostly backwards compatible.

@styfle styfle added the examples label Mar 17, 2020
@styfle styfle requested a review from AndyBitz Mar 17, 2020
@styfle styfle requested review from msweeneydev and timothyis as code owners Mar 17, 2020
@styfle styfle added the automerge label Mar 17, 2020
@styfle styfle changed the title [examples] Update jekyll and middleman to 2.1.4 [examples] Update jekyll and middleman to use bundler 2.1.4 Mar 17, 2020
@styfle styfle merged commit d32ab1e into master Mar 17, 2020
15 of 16 checks passed
15 of 16 checks passed
Unit Tests (ubuntu-latest, 10)
Details
Cancel Previous Runs
Details
Unit Tests (ubuntu-latest, 12)
Details
Unit Tests (macos-latest, 10)
Details
Unit Tests (macos-latest, 12)
Details
Unit Tests (windows-latest, 10)
Details
Unit Tests (windows-latest, 12)
Details
Integration Tests
Details
Now CLI Tests (ubuntu-latest, 10)
Details
Now CLI Tests (ubuntu-latest, 12) Now CLI Tests (ubuntu-latest, 12)
Details
`now dev` Tests (ubuntu-latest, 10)
Details
`now dev` Tests (ubuntu-latest, 12)
Details
`now dev` Tests (macos-latest, 10)
Details
`now dev` Tests (macos-latest, 12)
Details
kodiakhq: status 🛑 cannot merge (failing required status checks: {'Now CLI Tests (ubuntu-latest, 12)'})
Details
now Deployment has completed
Details
@styfle styfle deleted the jekyll-example branch Mar 17, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants
You can’t perform that action at this time.