Permalink
Commits on Apr 18, 2018
  1. Bumped version

    weierophinney committed Apr 18, 2018
  2. Renamed repository

    weierophinney committed Apr 18, 2018
    The repository has been renamed from "ZendDeveloperTools" to
    "zend-developer-tools", in order to make it consistent with other
    repository names, and to make it more consistent with tooling.
  3. Merge branch 'hotfix/248'

    weierophinney committed Apr 18, 2018
    Close #248
    Fixes #247
Commits on Apr 17, 2018
  1. Bumped version

    weierophinney committed Apr 17, 2018
  2. 1.2.0 readiness

    weierophinney committed Apr 17, 2018
  3. Updates branch aliases

    weierophinney committed Apr 17, 2018
    - dev-master => 1.2.x-dev
    - dev-develop => 1.3.x-dev
  4. Merge branch 'hotfix/qa-tools'

    weierophinney committed Apr 17, 2018
    Close #245
  5. Modernizes repository

    weierophinney committed Apr 17, 2018
    - Renames LICENSE.txt to LICENSE.md, and sets appropriate copyright range.
    - Adds issue and PR templates.
    - Adds code of conduct, contributing, and support guides.
    - Updates composer.json structure to match other components.
  6. Updates all file-level docblocks

    weierophinney committed Apr 17, 2018
    Updates all to use the new format (I found at least 4 different styles
    throughout the component!). Also removes redundant class-level
    license/copyright notices, and sorts all import statements.
  7. Use zend-coding-standard instead of phpcs+psr1+psr2

    weierophinney committed Apr 17, 2018
    This updates the package to use the zend-coding-standard, which adds a
    bunch of rules on top of the psr-1/2 checks we did previously via
    vanilla phpcs.
    
    The patch also includes fixes as reported (and fixed) by phpcs after
    updating the ruleset.
  8. Update to PHPUnit 5.7 and 6 series

    weierophinney committed Apr 17, 2018
    These provide full support for PHP 7. Doing so required updating test
    cases as these versions offer namespaced versions of their classes.
  9. Implement LEGACY_DEPS approach to Travis config

    weierophinney committed Apr 17, 2018
    Use LEGACY_DEPS to allow installing older PHPUnit versions on PHP 5.6
    and 7.0 targets.
  10. Merge branch 'hotfix/240'

    weierophinney committed Apr 17, 2018
    Close #240
  11. Merge pull request #240 from babwar/master

    weierophinney committed Apr 17, 2018
    Bug sliding toolbar on window resize
  12. Merge branch 'hotfix/238'

    weierophinney committed Apr 17, 2018
    Close #238
  13. Merge pull request #238 from localheinz/fix/undefined-class

    weierophinney committed Apr 17, 2018
    Fix: Remove service definition where classes don't exist
    
    Conflicts:
    	src/Module.php
  14. Merge branch 'hotfix/237'

    weierophinney committed Apr 17, 2018
    Close #237
  15. Merge pull request #237 from localheinz/fix/class-keyword

    weierophinney committed Apr 17, 2018
    Fix: Use class keyword
    
    Conflicts:
    	src/Module.php
  16. Merge branch 'hotfix/236'

    weierophinney committed Apr 17, 2018
    Close #236