Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

2.1.4: Zend/Stdlib/composer.json requires "Zend/Stdlib/compatibility/autoload.php" #4054

Closed
luebbert42 opened this Issue Mar 16, 2013 · 7 comments

Comments

Projects
None yet
5 participants

this "crashes" my app in dev env :-/

PHP Deprecated: Polyfill autoload support (file library/Zend/Stdlib/compatibility/autoload.php) is no longer necessary; please remove your require statement referencing this file in /path/to/my/app/vendor/zendframework/zend-stdlib/Zend/Stdlib/compatibility/autoload.php on line 14

"autoload": {
"psr-0": {
"Zend\Stdlib": ""
},
"files": [
"Zend/Stdlib/compatibility/autoload.php"
]
},

Member

Maks3w commented Mar 17, 2013

This is fixed in master.

/cc @weierophinney Can we tag 9a91eff as 2.1.4.1 for stdlib package?

Owner

weierophinney commented Mar 17, 2013

Syncing the repos is unfortunately broken for the foreseeable future;
subsplit was consuming all my available system inodes after only a few days
of tunning he syncing process. The author has some changes for me to try,
but it will likely be a week or two before I can recreate the subsplits and
try the changes.
On Mar 17, 2013 10:19 AM, "Maks" notifications@github.com wrote:

This is fixed in master.

/cc @weierophinney https://github.com/weierophinney Can we tag 9a91effhttps://github.com/zendframework/zf2/commit/9a91effa637a1a629fcb3dd6e2a4742d78ea0a7eas 2.1.4.1 for stdlib package?


Reply to this email directly or view it on GitHubhttps://github.com/zendframework/zf2/issues/4054#issuecomment-15024288
.

Member

Maks3w commented Mar 17, 2013

I don't see very important changes between 2.1.4 tag and 3319f62 / 061ad98

i also get this error using composer to install components:

{
  "repositories": [
    {
      "type": "composer",
      "url": "https://packages.zendframework.com/"
    }
  ],
  "autoload": {
    "psr-0": { "namespace": "src/" }
  },
  "require": {
    "zendframework/zend-captcha": "2.*",
    "zendframework/zend-config": "2.*",
    "zendframework/zend-eventmanager": "2.*",
    "zendframework/zend-form": "2.*",
    "zendframework/zend-http": "2.*",
    "zendframework/zend-inputfilter": "2.*",
    "zendframework/zend-mail": "2.*",
    "zendframework/zend-navigation": "2.*",
    "zendframework/zendpdf": "2.*",
    "zendframework/zend-permissions-acl": "2.*",
    "zendframework/zendservice-recaptcha": "2.*",
    "zendframework/zend-session": "2.*",
    "zendframework/zend-validator": "2.*",
    "zendframework/zend-view": "2.*"
  }
}

Deprecated: Polyfill autoload support (file library/Zend/Stdlib/compatibility/autoload.php) is no longer necessary; please remove your require statement referencing this file in ...Zend/Stdlib/compatibility/autoload.php on line 14

Owner

weierophinney commented Mar 20, 2013

I don't see very important changes between 2.1.4 tag and 3319f62 / 061ad98

@Maks3w - We changed the composer.json in Zend/Stdlib/ to remove the autoload.files entry, which resolves this issue. However, with the in ability to sync the component repos, the only way to get the update is to install the full framework.

Member

padraic commented Mar 29, 2013

Any updates on this? Ran into it this morning installing Zend\Uri... Is everything using stdlib now unusable from Composer?

Owner

weierophinney commented Mar 29, 2013

@padraic It's fixed on master, and the component repos are all synced at this time: https://github.com/zendframework/Component_ZendStdlib/blob/master/composer.json#L9-L13

When we bump to 2.1.5, we'll have a stable version with the correct information.

@ghost ghost assigned weierophinney Mar 29, 2013

@ahurt2000 ahurt2000 referenced this issue in BeSimple/BeSimpleSoapBundle Jul 23, 2013

Closed

warning "Zend PHP Deprecated: Polyfill autoload" #60

iteman pushed a commit to iteman/BEAR.Package that referenced this issue Jun 14, 2014

iteman pushed a commit to iteman/BEAR.Package that referenced this issue Jun 14, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment