Composer inconsistant versions with zend website #4156

Closed
shaunfreeman opened this Issue Mar 31, 2013 · 2 comments

Comments

Projects
None yet
2 participants
Contributor

shaunfreeman commented Mar 31, 2013

I have come accross an inconstancy with versions.

Zend downloads and zendframework websites are recommending zend framework 2.1.4 as the stable versions but if you install zendframework with composer and your minimum requirements are set to stable then zendframwork 2.0.8 is installed.

This is a problem because if you are using features that are in 2.1.4 but not in 2.0.8 then you have a problem.

Also this also looks bad to customers as they think they are getting an unstable version as we have to force composer to download with minimum requirements set to 'dev'.

And if you install a module with zendframework as a requirement then composer will replace 2.1.* with 2.0.8.

Please could each release for composer reflect what framework.zend.com are say is stable please. This really does need fixing.

Contributor

ThaDafinser commented Jul 30, 2013

@shaunfreeman is this still a problem? I think with 2.2 series this is fine

Can get closed?

Contributor

shaunfreeman commented Aug 1, 2013

no not a problem with the 2.2 series, seems to be fixed now thanks.

This issue can be closed now

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment