Require PHP extension mcrypt in composer.json #6037

Closed
maxailloud opened this Issue Mar 25, 2014 · 6 comments

Comments

Projects
None yet
3 participants

The ZendCrypt component require the mcrypt PHP extension to work but this extension is not in the require section in its composer.json, or even in this repository composer.json file.

Maybe you should add it.

Member

Maks3w commented Mar 25, 2014

Should have a mention in the suggest section. require can't be choose because is able to work with alternative extensions.

Do you want to send a patch? (https://github.com/zendframework/zf2/blob/master/library/Zend/Crypt/composer.json)

@Maks3w Maks3w added this to the 2.3.1 milestone Mar 25, 2014

@Maks3w Maks3w added Crypt labels Mar 25, 2014

Okay I'll do the patch.

Which extension can be used with this component? (just for my information)

Member

Maks3w commented Mar 25, 2014

mcrypt, openssl, ... depend of your use case

Ok I see.

Contributor

samsonasik commented Apr 5, 2014

@maxailloud do you working on it ?

Just didn't have time to.

weierophinney added a commit that referenced this issue Apr 14, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment