Update minimum required PHP version to 5.3.23 #5602

Merged
merged 1 commit into from Dec 10, 2013

Projects

None yet

4 participants

@weierophinney
Member

Per discussion on the ML, and per technical issues we've been attempting to
resolve within the framework.

5.3.23 was chosen for the following reasons:

  • 5.3.9 and up have a fix that allows a class to implement multiple interfaces
    that define the same method, so long as the signatures are compatible. Prior
    to that version, doing so raised a fatal error. This change is necessary in
    order to solve a problem with separated interface usage in the framework.
  • 5.3.23 contains a PHP bug #62672.
    Adopting this version or greater will allow us to (eventually) remove polyfill
    support that works around the symptoms of that issue.

There were no compelling fixes in later versions of the 5.3 series that made
sense, other than 5.3.27, as the last 5.3 version released.

@weierophinney weierophinney Update minimum required PHP version to 5.3.23
- Per discussion on the ML, and per technical issues we've been attempting to
  resolve within the framework.
af3e982
@Ocramius
Member

This is huge, but 👍

@ralphschindler ralphschindler added a commit that referenced this pull request Dec 10, 2013
@ralphschindler ralphschindler Merging PR #5602
Merge branch 'weierophinney-feature/new-minimum-php-version' into develop

* weierophinney-feature/new-minimum-php-version:
  Update minimum required PHP version to 5.3.23
350ba4e
@ralphschindler ralphschindler merged commit af3e982 into zendframework:develop Dec 10, 2013

1 check passed

default The Travis CI build passed
Details
@weierophinney weierophinney deleted the weierophinney:feature/new-minimum-php-version branch Dec 12, 2013
@samsonasik
Contributor

I created PR #5604 to change php require version from 5.3.3 to 5.3.23 in all resources and update tests that no longer support 5.3.3

@weierophinney weierophinney pushed a commit to zendframework/zend-i18n-resources that referenced this pull request May 28, 2015
@ralphschindler ralphschindler Merging PR zendframework/zendframework#5602
Merge branch 'weierophinney-feature/new-minimum-php-version' into develop

* weierophinney-feature/new-minimum-php-version:
  Update minimum required PHP version to 5.3.23
61bb631
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment