Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Rely on the autoloader to load PHPUnit_Runner_Version and PHPUnit_Autoload #297

Merged
merged 1 commit into from

3 participants

@bskendig

Note that I've removed the test that loads PHPUnit_Framework for PHPUnit before 3.5, PHPUnit_Autoload for PHPUnit 3.5 and later. I assume no one will be using the latest ZF1 with such an old PHPUnit.

Brian Kendig Rely on the autoloader to load PHPUnit_Runner_Version and PHPUnit_Aut…
…oload, instead of requiring their files directly.
18327f1
@bskendig bskendig referenced this pull request in sebastianbergmann/phpunit
Closed

PHPUnit 4.0 doesn't have Runner class to get the version #1167

@froschdesign froschdesign added this to the 1.12.6 milestone
@akrabat akrabat merged commit 18327f1 into zendframework:master

1 check failed

Details default The Travis CI build failed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Mar 7, 2014
  1. Rely on the autoloader to load PHPUnit_Runner_Version and PHPUnit_Aut…

    Brian Kendig authored
    …oload, instead of requiring their files directly.
This page is out of date. Refresh to see the latest.
Showing with 0 additions and 9 deletions.
  1. +0 −9 library/Zend/Test/PHPUnit/ControllerTestCase.php
View
9 library/Zend/Test/PHPUnit/ControllerTestCase.php
@@ -19,15 +19,6 @@
* @version $Id$
*/
-/** @see PHPUnit_Runner_Version */
-require_once 'PHPUnit/Runner/Version.php';
-
-/**
- * Depending on version, include the proper PHPUnit support
- * @see PHPUnit_Autoload
- */
-require_once (version_compare(PHPUnit_Runner_Version::id(), '3.5.0', '>=')) ? 'PHPUnit/Autoload.php' : 'PHPUnit/Framework.php';
-
/** @see Zend_Controller_Front */
require_once 'Zend/Controller/Front.php';
Something went wrong with that request. Please try again.