Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Version warning http:// wrapper is disabled in the server configuration by allow_url_fopen=0 #4610

Closed
xorock opened this Issue · 1 comment

2 participants

@xorock

Please add an additional check to eliminate warning:

Warning: fopen(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in .../Zend/Version/Version.php on line 95
Warning: fopen(http://framework.zend.com/api/zf-version?v=2): failed to open stream: no suitable wrapper could be found in .../Zend/Version/Version.php on line 95

@weierophinney

I'd argue we should check that INI setting and issue an E_USER_WARNING in that situation, returning a boolean false. Alternately, or additionally, we should allow passing an HTTP client as a second argument to the method, which would allow you to continue to contact the service when the stream wrapper is unavailable.

@weierophinney weierophinney referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.