Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Update minimum required PHP version to 5.3.23 #5602

Merged
merged 1 commit into from

4 participants

@weierophinney

Per discussion on the ML, and per technical issues we've been attempting to
resolve within the framework.

5.3.23 was chosen for the following reasons:

  • 5.3.9 and up have a fix that allows a class to implement multiple interfaces
    that define the same method, so long as the signatures are compatible. Prior
    to that version, doing so raised a fatal error. This change is necessary in
    order to solve a problem with separated interface usage in the framework.

  • 5.3.23 contains a PHP bug #62672.
    Adopting this version or greater will allow us to (eventually) remove polyfill
    support that works around the symptoms of that issue.

There were no compelling fixes in later versions of the 5.3 series that made
sense, other than 5.3.27, as the last 5.3 version released.

@weierophinney weierophinney Update minimum required PHP version to 5.3.23
- Per discussion on the ML, and per technical issues we've been attempting to
  resolve within the framework.
af3e982
@Ocramius
Collaborator

This is huge, but :+1:

@ralphschindler ralphschindler referenced this pull request from a commit
@ralphschindler ralphschindler Merging PR #5602
Merge branch 'weierophinney-feature/new-minimum-php-version' into develop

* weierophinney-feature/new-minimum-php-version:
  Update minimum required PHP version to 5.3.23
350ba4e
@ralphschindler ralphschindler merged commit af3e982 into zendframework:develop

1 check passed

Details default The Travis CI build passed
@weierophinney weierophinney deleted the weierophinney:feature/new-minimum-php-version branch
@samsonasik

I created PR #5604 to change php require version from 5.3.3 to 5.3.23 in all resources and update tests that no longer support 5.3.3

@weierophinney weierophinney referenced this pull request from a commit in zendframework/zend-i18n-resources
@ralphschindler ralphschindler Merging PR zendframework/zf2#5602
Merge branch 'weierophinney-feature/new-minimum-php-version' into develop

* weierophinney-feature/new-minimum-php-version:
  Update minimum required PHP version to 5.3.23
61bb631
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 10, 2013
  1. @weierophinney

    Update minimum required PHP version to 5.3.23

    weierophinney authored
    - Per discussion on the ML, and per technical issues we've been attempting to
      resolve within the framework.
This page is out of date. Refresh to see the latest.
Showing with 18 additions and 2 deletions.
  1. +0 −1  .travis.yml
  2. +17 −0 README.md
  3. +1 −1  composer.json
View
1  .travis.yml
@@ -1,7 +1,6 @@
language: php
php:
- - 5.3.3
- 5.3
- 5.4
- 5.5
View
17 README.md
@@ -17,6 +17,23 @@ DD MMM YYY
### UPDATES IN 2.3.0
+This release ups the minimum required PHP version from 5.3.3 to **5.3.23**.
+Making this change affords the following:
+
+- 5.3.9 and up have a fix that allows a class to implement multiple interfaces
+ that define the same method, so long as the signatures are compatible. Prior
+ to that version, doing so raised a fatal error. This change is necessary in
+ order to solve a problem with separated interface usage in the framework.
+
+- 5.3.23 contains a [PHP bug #62672](https://bugs.php.net/bug.php?id=52861).
+ Adopting this version or greater will allow us to (eventually) remove polyfill
+ support that works around the symptoms of that issue.
+
+As always, the Zend Framework project strongly recommends using the latest
+version of PHP available to ensure you have the latest security fixes.
+
+Additional updates that may affect existing applications include:
+
- [#5587](https://github.com/zendframework/zf2/pull/5587) changes the default
cost for `Zend\Crypt\Password\Bcrypt` to 10, to keep it consistent with PHP's
own default, as well as potentially mitigate DoS vectors (due to high
View
2  composer.json
@@ -30,7 +30,7 @@
}
],
"require": {
- "php": ">=5.3.3"
+ "php": ">=5.3.23"
},
"require-dev": {
"doctrine/annotations": ">=1.0",
Something went wrong with that request. Please try again.