Skip to content
Permalink
Browse files

Adding support for Elasticsearch 7.3.1. Updated Jackson dependency to…

… resolve security vulnerabilities CVE-2019-14379, CVE-2019-14439.
  • Loading branch information...
davemoore- committed Aug 23, 2019
1 parent 35b3047 commit 189e41282d17d9b16ce6694dfb45ee9ad6820f01
Showing with 5 additions and 4 deletions.
  1. +1 −0 .travis.yml
  2. +1 −1 README.md
  3. +3 −3 pom.xml
@@ -3,6 +3,7 @@ jdk:
- oraclejdk8
env:
matrix:
- ELASTICSEARCH_VERSION=7.3.1
- ELASTICSEARCH_VERSION=7.3.0
- ELASTICSEARCH_VERSION=7.2.1
- ELASTICSEARCH_VERSION=7.2.0
@@ -31,7 +31,7 @@ Once you have installed Elasticsearch, you can install zentity from a remote URL

Example:

`elasticsearch-plugin install https://zentity.io/releases/zentity-1.4.0-elasticsearch-7.3.0.zip`
`elasticsearch-plugin install https://zentity.io/releases/zentity-1.4.1-elasticsearch-7.3.1.zip`

Read the [installation](https://zentity.io/docs/installation) docs for more details.

@@ -14,11 +14,11 @@
<zentity.author>Dave Moore</zentity.author>
<zentity.classname>org.elasticsearch.plugin.zentity.ZentityPlugin</zentity.classname>
<zentity.website>https://zentity.io</zentity.website>
<zentity.version>1.4.0</zentity.version>
<zentity.version>1.4.1</zentity.version>
<!-- dependency versions -->
<elasticsearch.version>7.3.0</elasticsearch.version>
<elasticsearch.version>7.3.1</elasticsearch.version>
<jackson.core.version>2.9.9</jackson.core.version>
<jackson.databind.version>2.9.9.1</jackson.databind.version>
<jackson.databind.version>2.9.9.2</jackson.databind.version>
<jdk.version>1.8</jdk.version>
<log4j.version>2.9.1</log4j.version>
<commons-io.version>2.6</commons-io.version>

0 comments on commit 189e412

Please sign in to comment.
You can’t perform that action at this time.