Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't install zentyal-samba on 18.04.4 - libauthen-krb5-easy-perl is not installable #1946

Open
mrPsycho opened this issue Feb 16, 2020 · 2 comments
Labels

Comments

@mrPsycho
Copy link

@mrPsycho mrPsycho commented Feb 16, 2020

Describe the bug
After fresh install of ubuntu server 18.04.4 and using https://wiki.zentyal.org/wiki/Installation_Guide#Zentyal_Installer_script it is not possible to install zentyal-samba.

To Reproduce
Steps to reproduce the behavior:

  1. go to ubuntu.com and download http://releases.ubuntu.com/18.04.4/ubuntu-18.04.4-live-server-amd64.iso
  2. install server with default settings
  3. reboot and login to clean system
  4. try to run
curl -s download.zentyal.com/install | sudo sh
sudo apt install zentyal-samba
  1. see error:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-samba : Depends: libauthen-krb5-easy-perl but it is not installable
E: Unable to correct problems, you have held broken packages.

Expected behavior
It is installing without any problems.

Screenshots
Same error on UI:
image

Zentyal OS (please complete the following information):

  • Version: 6.1
  • Version of the module which has the bug: Idk, it is not installing.
  • Modules installed:
zentyal-core/unknown,now 6.1.2 all [installed]
zentyal-software/unknown,now 6.1 all [installed]
@mrPsycho mrPsycho added the Type: Bug label Feb 16, 2020
@lukaspavelka

This comment has been minimized.

Copy link

@lukaspavelka lukaspavelka commented Feb 25, 2020

i can confirm this bug on ubuntu 18.04 with installation of

root@vps:~# apt-get install zentyal-samba
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
zentyal-samba : Depends: libauthen-krb5-easy-perl but it is not installable
E: Unable to correct problems, you have held broken packages.


root@vps:~# apt-get install libauthen-krb5-easy-perl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libauthen-krb5-easy-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libauthen-krb5-easy-perl' has no installation candidate


root@vps:~# apt-get install -y libauthen-krb5-perl
Reading package lists... Done
Building dependency tree
Reading state information... Done
libauthen-krb5-perl is already the newest version (1.9-5build3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

@Neustradamus

This comment has been minimized.

Copy link

@Neustradamus Neustradamus commented Mar 26, 2020

Any news?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.