Skip to content
Permalink
Browse files

boards: arm: mps2_an521: some trivial Kconfig fixes

When TRUSTED_EXECUTION_NONSECUCRE is selected, we always
define the default board (mps2_an521). We do not need to
OR with TRUSTED_EXECUTION_SECURE, in this Kconfig
conditional.

In addition to that, we make the BOARD_MPS2_AN521 board
to strictly depend on the corresponding SOC, not on the
SOC series.

Signed-off-by: Ioannis Glaropoulos <Ioannis.Glaropoulos@nordicsemi.no>
  • Loading branch information...
ioannisg authored and andrewboie committed Jul 16, 2019
1 parent 089127c commit f8c37d56fd18fcdad394748acebb3139189f7683
Showing with 3 additions and 3 deletions.
  1. +1 −1 boards/arm/mps2_an521/Kconfig.board
  2. +2 −2 boards/arm/mps2_an521/Kconfig.defconfig
@@ -6,6 +6,6 @@

config BOARD_MPS2_AN521
bool "ARM Cortex-M33 SMM on V2M-MPS2 (AN521)"
depends on SOC_SERIES_MPS2
depends on SOC_MPS2_AN521
select QEMU_TARGET
select HAS_COVERAGE_SUPPORT
@@ -6,7 +6,7 @@

if BOARD_MPS2_AN521

if TRUSTED_EXECUTION_SECURE || !TRUSTED_EXECUTION_NONSECURE
if !TRUSTED_EXECUTION_NONSECURE

config BOARD
default "mps2_an521"
@@ -18,7 +18,7 @@ if TRUSTED_EXECUTION_NONSECURE
config BOARD
default "mps2_an521_nonsecure"

endif
endif # !TRUSTED_EXECUTION_NONSECURE

if GPIO

0 comments on commit f8c37d5

Please sign in to comment.
You can’t perform that action at this time.