Permalink
Browse files

Only use install_requires if setuptools/distribute is available

  • Loading branch information...
1 parent 1fd8070 commit 97bda4d1d10ea732a30f40b7dc7c6af4c264fe51 @zerok committed Oct 30, 2013
Showing with 8 additions and 4 deletions.
  1. +8 −4 setup.py
View
@@ -1,4 +1,10 @@
-from distutils.core import setup
+try:
+ from setuptools import setup
+ kws = {'install_requires': ['Django']}
+except:
+ from distutils.core import setup
+ kws = {}
+
setup(
name='django-flatblocks',
@@ -40,7 +46,5 @@
'locale/*/*/*.po',
]
},
- install_requires=[
- 'Django',
- ]
+ **kws
)

0 comments on commit 97bda4d

Please sign in to comment.