Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

gem should install without configuration when zqm is installed in well known places #10

Closed
skaes opened this Issue · 0 comments

2 participants

Stefan Kaes Brian Buchanan
Stefan Kaes
skaes commented

the way extconf.rb is written, installing the gem fails quite often, even though libzmq and headers are installed in well known places.

$ ruby extconf.rb 
checking for zmq_init() in -lzmq... no
extconf.rb:25: Couldn't find zmq library. try setting --with-zmq-dir=<path> to tell me where it is. (RuntimeError)

$ locate zmq.h
/opt/local/include/zmq.h
/opt/local/include/zmq.hpp
/opt/local/var/macports/software/zmq/2.1.7_0+pgm/opt/local/include/zmq.h
/opt/local/var/macports/software/zmq/2.1.7_0+pgm/opt/local/include/zmq.hpp

Having to specify --with-zmq-dir is a nuisance, especially in combination with using bundler.

I'm going to submit a patch.

Stefan Kaes skaes referenced this issue from a commit in skaes/rbzmq
Stefan Kaes skaes should install automagically on most platforms now fixes #10
without resorting to --with-zmq-dir=<path>, which is painful to use with bundler
5baf773
Michael Granger ged referenced this issue from a commit
Commit has since been removed from the repository and is no longer available.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.