Skip to content
Permalink
Browse files

kmod-zfs-devel rpm should provide kmod-spl-devel

When configure is run with --with-spec=redhat, and rpms are built, the
kmod-zfs-devel package is missing

Provides: kmod-spl-devel = %{version}

which is required by software such as Lustre which builds against zfs
kmods.  Adding it makes it easier for such software to build against
both zfs-0.7 (where SPL is separate and may be missing) and zfs-0.8.

Reviewed-by: Tony Hutter <hutter2@llnl.gov>
Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov>
Signed-off-by: Olaf Faaland <faaland1@llnl.gov>
Closes #8930
  • Loading branch information...
ofaaland authored and tonyhutter committed Jun 19, 2019
1 parent 336744d commit 50e80510aaa559681b83d13e2234cc8a6317e5e3
Showing with 1 addition and 0 deletions.
  1. +1 −0 rpm/redhat/zfs-kmod.spec.in
@@ -41,6 +41,7 @@ This package contains the ZFS kernel modules.
%package -n kmod-%{kmod_name}-devel
Summary: ZFS kernel module(s) devel common
Group: System Environment/Kernel
Provides: kmod-spl-devel = %{version}

%description -n kmod-%{kmod_name}-devel
This package provides the header files and objects to build kernel modules.

0 comments on commit 50e8051

Please sign in to comment.
You can’t perform that action at this time.