Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Doesn't work on OSX 10.13 #19

Open
V3kb opened this issue Sep 25, 2017 · 24 comments
Open

Doesn't work on OSX 10.13 #19

V3kb opened this issue Sep 25, 2017 · 24 comments

Comments

@V3kb
Copy link

V3kb commented Sep 25, 2017

Doesn't work on OSX 10.11,please update !

@bdel
Copy link

bdel commented Sep 28, 2017

Same! Help! :(

@singhprd
Copy link

singhprd commented Oct 1, 2017

This seems to be to do with updated system Ruby on Mac OS. I can't actually find any other documentation on this, but in High Sierra, my system Ruby seems to be 2.3.3 and this workflow isn't able to install bundler, and the correct gems to get itself working.
I've been able to fiddle with bundle myself manually and fix the workflow, but haven't been able to get this to work automatically inside the workflow with system ruby yet.

@zhaocai your workflows are fantastic, and whenever you get a chance, it would be really great to see them updated! 😄

@singhprd
Copy link

singhprd commented Oct 1, 2017

Ok so what you need to do to fix this is right click from Alfred preferences then "Open in Terminal".
This will take you to where the workflow is stored.

Then we just need to do a "bundle install --standalone". This however doesn't work on system ruby, due to bundler not being installed.
I changed to another install of system ruby - 2.3.3 - which had bundler installed - then performed the above command.
Now you can use the workflow again.

@pjpjq
Copy link

pjpjq commented Oct 5, 2017

I changed to another install of system ruby - 2.3.3 - which had bundler installed - then performed the above command.

@singhprd can you provide more details about that please?

@singhprd
Copy link

singhprd commented Oct 6, 2017

https://github.com/singhprd/alfred2-top-workflow/releases/download/v2.2/Top.Processes.v2.2.alfredworkflow
@wendingp Try this newly packaged workflow and let me know if it works 👍

@pjpjq
Copy link

pjpjq commented Oct 6, 2017

@singhprd Cool it works. Thx!!!

@warb2n
Copy link

warb2n commented Oct 7, 2017

@singhprd Thank you so much!

@9h0st
Copy link

9h0st commented Oct 9, 2017

glance command not work

#<Errno::ENOENT:` No such file or directory - ./bin/smc>
......
/bundle/ruby/2.3.0/gems/mixlib-shellout-1.2.0/lib/mixlib/shellout/unix.rb:268:in `exec' 
......
./glance.rb:24:in `sh'  
./glance.rb:59:in `collect_temperature'  
./glance.rb:48:in `collect'  
./glance.rb:315:in `generate_feedback'  
./glance.rb:324:in `block in <main>'  
......
/bundle/ruby/2.3.0/gems/alfred-workflow-2.0.5/lib/alfred.rb:82:in `with_friendly_error'  
./glance.rb:322:in `<main>'

@xiaobocser
Copy link

@singhprd thx! it's great !

@arthurkiller
Copy link

Same problem,

@singhprd Awsome dude! Thx alot

@arthurkiller
Copy link

Why no start a PR? @singhprd

@singhprd
Copy link

singhprd commented Oct 20, 2017

@arthurkiller The changes I've made are just re-packaging the Gems for new system ruby (2.3.3) and including them in the release.
@zhaocai will need to do this as I don't think I can submit a PR for a release.

@9h0st - Looks like Glance isn't working because /usr/local/bin/smc no longer exists?
I'm guessing Apple removed it in High Sierra.
We need a new way to access SMC controller and run commands like this, before it can be fixed:
smc -k "TC0P" -r -c
Maybe from here, but I can't get it working?:
https://github.com/hholtmann/smcFanControl/tree/master/smc-command

@singhprd
Copy link

singhprd commented Oct 25, 2017

@9h0st - I've now updated so that Glance now works, but I've had to remove some features.
https://github.com/singhprd/alfred2-top-workflow/releases/tag/v2.3

More feature requests welcome.

@FrizzleFur
Copy link

@singhprd Awesome work, bro! You make it worked again!👍

@NeverMoes
Copy link

@9h0st - I've now updated so that Glance now works, but I've had to remove some features.
https://github.com/singhprd/alfred2-top-workflow/releases/tag/v2.3

More feature requests welcome.

thanks very much bro.

@KilluaaaCHEN
Copy link

@singhprd I am also the same problem. Now it's working. thank you so much !

@lxwvictor
Copy link

@singhprd Awesome! Now everything works!

@zivan80
Copy link

zivan80 commented Jul 31, 2019

@singhprd 感谢你的修正,macos10.13.6 测试全部工作正常

@lowking
Copy link

lowking commented Sep 30, 2019

@singhprd Thx, it works for macOS 10.14.5

@linivor
Copy link

linivor commented Nov 17, 2019

Doesn't work on OSX 10.15, please update!

@ryan6416
Copy link

Any update for 10.15?

1 similar comment
@ouyangjunyi
Copy link

Any update for 10.15?

@arthurkiller
Copy link

arthurkiller commented Mar 5, 2020

os: 10.15
appversion: 3.8.1

works properly for me

@Xinghanzzy
Copy link

os: 10.15
appversion: 4.0.7

thank you

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests