Permalink
Browse files

0.0.5 - require it yourself

There's an issue on Linux when 'gdal/gdal' and 'gdal/ogr' are both
require'd together. Gdal::Ogr.get_driver_by_name will return a
Gdal::Gdal::Driver and not a Gdal::Ogr::Driver. So this version
removes the automatic requires and you can require what you need.
  • Loading branch information...
1 parent b033d82 commit d0a2c221a7ff0da427e5bd0d00bcd300413408a4 @zhm committed Aug 17, 2012
Showing with 3 additions and 6 deletions.
  1. +1 −1 README.md
  2. +1 −1 lib/gdal-ruby/version.rb
  3. +0 −3 lib/gdal.rb
  4. +1 −1 spec/gdal_spec.rb
View
@@ -42,7 +42,7 @@ Or install it yourself as:
To test it out:
- $ ruby -e "require 'gdal'; puts Gdal::Ogr.create_geometry_from_wkt('POINT (30 10)').export_to_json"
+ $ ruby -e "require 'gdal-ruby/ogr'; puts Gdal::Ogr.create_geometry_from_wkt('POINT (30 10)').export_to_json"
The best documentation for right now is the [autotest](http://trac.osgeo.org/gdal/browser/trunk/autotest/ruby/ogr) code in the GDAL source tree. You can see various
patterns for accessing files and using the OGR API from the autotest sources.
@@ -1,5 +1,5 @@
module Gdal
module Ruby
- VERSION = "0.0.4"
+ VERSION = "0.0.5"
end
end
View
@@ -1,4 +1 @@
require 'gdal-ruby/version'
-require 'gdal-ruby/ogr'
-require 'gdal-ruby/gdal'
-require 'gdal-ruby/gdalconst'
View
@@ -1,4 +1,4 @@
-require 'gdal'
+require 'gdal/ogr'
describe "Gdal" do
it "converts WKT to GeoJSON" do

0 comments on commit d0a2c22

Please sign in to comment.