after upgrade 1.4.4 to 1.4.5 categories broken in News #3356

Closed
rallek opened this Issue Jan 1, 2017 · 1 comment

Projects

None yet

2 participants

@rallek
Contributor
rallek commented Jan 1, 2017
Q A
Zikula Version 1.4.5 stable
PHP Version 5.5.30

Expected behavior

editing of news should work like in 1.4.4

Actual behavior

can not edit News anymore. Have not tested other modules with categories in use.

Fatal error: Call to undefined method Zikula\CategoriesModule\Helper\HtmlTreeHelper::getSelector() in /home/www/www.oldtimer-ig-osnabrueck.de/Zikula_Core-1.4.5/lib/legacy/util/CategoryUtil.php on line 592

Oops! An Error Occurred
The server returned a "500 Internal Server Error".
Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.

Attempted to call an undefined method named "getSelector" of class "Zikula\CategoriesModule\Helper\HtmlTreeHelper". Did you mean to call "getSelector_Categories"?

Steps to reproduce

Have an site with news on it, upgrade to 1.4.4 and try to edit a news.

That looks like:
grafik

@Guite Guite self-assigned this Jan 1, 2017
@Guite Guite added the Bug label Jan 1, 2017
@Guite Guite added this to the 1.4.6 milestone Jan 1, 2017
@Guite Guite added a commit that closed this issue Jan 1, 2017
@Guite Guite fixed #3356 7b3fb8d
@Guite Guite closed this in 7b3fb8d Jan 1, 2017
@rallek
Contributor
rallek commented Jan 1, 2017

Wow! thats fast! And I can confirm that it is working well!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment