Skip to content
Swvim is a little vim package. It's lightweight and optimized for rails development in terminal vim.
VimL Ruby Shell
Pull request Compare This branch is 16 commits ahead, 9 commits behind SweeD:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
test
vim
.gitignore
.rbenv-version
.ruby-version
Gemfile
README.md
Rakefile
install.sh
swvimrc

README.md

Swvim Build Status

Swvim is a little vim package. It's lightweight and optimized for rails development in terminal vim.

Requirements

Just be sure that you have 256 colors enabled in your terminal.

For example:

~  tput colors
256

➜  ~  echo $TERM
xterm-256color

Setup

Be sure that you don't have any .vim.old .vimrc.old .gvimrc.old in your home directory.

Then do

git clone git@github.com:zirni/swvim.git ~/.swvim
cd ~/.swvim
./install.sh

Now you have to follow these steps to finish the installation:

bundle
RUBYOPT='-E utf-8' vim-update-bundles

And now you're ready to go!

Customization

You can add your own configurations in ~/.vimrc.local to customize the config to your needs.

Something went wrong with that request. Please try again.