Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support for rrdtool 1.5.x (crashes now) #24

Open
xor-gate opened this issue May 18, 2015 · 7 comments
Open

Support for rrdtool 1.5.x (crashes now) #24

xor-gate opened this issue May 18, 2015 · 7 comments

Comments

@xor-gate
Copy link

@xor-gate xor-gate commented May 18, 2015

Dear Michał,

As Facette uses your rrd library for golang I experienced crashes when my ArchLinux system upgraded to rrdtool 1.4.x to 1.5.x. Is there any chance you will add extra support for rrdtool 1.5.x in the future?

Here is the original issue:
facette/facette#207

Kind regards,
Jerry

@ziutek

This comment has been minimized.

Copy link
Owner

@ziutek ziutek commented May 18, 2015

I don't use 1.5.x and have no any system with it. Debian Wheezy has 1.4.7. Debian SID on my desktop has 1.4.8. I probably will try to add support for 1.5.x when Debian SID will contain it.

@xor-gate

This comment has been minimized.

Copy link
Author

@xor-gate xor-gate commented Aug 16, 2015

Hi there @ziutek I want to let you know that librrd 1.5.x has moved into Debian Sid: https://packages.debian.org/sid/librrd4

@pandada8

This comment has been minimized.

Copy link

@pandada8 pandada8 commented Sep 3, 2015

+1

@ziutek

This comment has been minimized.

Copy link
Owner

@ziutek ziutek commented Sep 23, 2015

I run go test on my desktop with librrd4 1.5.4-5 without any errors. Can someone provide code that crash on similar librrd version?

@falzm

This comment has been minimized.

Copy link

@falzm falzm commented Dec 21, 2015

Hi @ziutek, looks like we have another Facette user that faces crashes related to this issue: facette/facette#285 (using librrd4 1.5.4).

@xor-gate

This comment has been minimized.

Copy link
Author

@xor-gate xor-gate commented Dec 21, 2015

Maybe @ziutek should get those rrd files which crash facette @falzm ? If those files are properly loaded/tested by the go rrd library implementation then it is something in facette.

@ziutek

This comment has been minimized.

Copy link
Owner

@ziutek ziutek commented Jan 8, 2016

ii librrd-dev:amd64 1.5.5-3+b1 amd64 time-series data storage and display system (development)
ii librrd4:amd64 1.5.5-3+b1 amd64 time-series data storage and display system (runtime library)

~/P/go/src/github.com/ziutek/rrd$ go test

[cut]

PASS
ok github.com/ziutek/rrd 20.339s

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.