Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 21 lines (18 sloc) 0.601 kB
3866d49 initial conversion to bundler 1.0.0
Chad Humphries and Jon Distad authored
1 begin
2 require "rubygems"
3 require "bundler"
4 rescue LoadError
5 raise "Could not load the bundler gem. Install it with `gem install bundler`."
6 end
7
8 if Gem::Version.new(Bundler::VERSION) <= Gem::Version.new("0.9.24")
9 raise RuntimeError, "Your bundler version is too old for Rails 2.3." +
10 "Run `gem install bundler` to upgrade."
11 end
12
13 begin
14 # Set up load paths for all bundled gems
15 ENV["BUNDLE_GEMFILE"] = File.expand_path("../../Gemfile", __FILE__)
16 Bundler.setup
17 rescue Bundler::GemNotFound
18 raise RuntimeError, "Bundler couldn't find some gems." +
19 "Did you run `bundle install`?"
20 end
Something went wrong with that request. Please try again.