New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

osx 10.11.6 doesn't work #785

Closed
nopara73 opened this Issue Nov 2, 2018 · 5 comments

Comments

Projects
None yet
3 participants
@nopara73
Collaborator

nopara73 commented Nov 2, 2018

dyld: lazy symbol binding failed: Symbol not found: _clock_gettime
  Referenced from: /Applications/WasabiOsx/libcoreclr.dylib (which was built for Mac OS X 10.12)
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _clock_gettime
  Referenced from: /Applications/WasabiOsx/libcoreclr.dylib (which was built for Mac OS X 10.12)
  Expected in: /usr/lib/libSystem.B.dylib

Trace/BPT trap: 5

pocoproject/poco#1453 (comment)

clock_gettime() was added in macOS 10.12. You need to build against an earlier SDK if you want to be backwards compatible.

.NET Core supports from > osx.10.10-x64 so this should be fixed.

@lontivero

This comment has been minimized.

Contributor

lontivero commented Nov 2, 2018

.NET Core 2.1 supports OSX 10.12+ https://github.com/dotnet/core/blob/master/release-notes/2.1/2.1-supported-os.md.

As the comment says, clock_gettime() was added in Sieraa (10.12) and is not available in older versions.

@nopara73

This comment has been minimized.

Collaborator

nopara73 commented Nov 2, 2018

You can publish to runtime osx.10.10-x64 and we currently do, so that's why we should attempt to fix it. (If it's the only issue.)

@danwalmsley

This comment has been minimized.

Contributor

danwalmsley commented Nov 7, 2018

@nopara73 Avalonia osx backend doesn't make this call. The issue is in .net core.

"osx-x64 (.NET Core 2.0 or later versions, minimum version is osx.10.12-x64)"

from: https://github.com/dotnet/docs/blob/master/docs/core/rid-catalog.md

Avalonia supports .netcore2.0 minimum unfortunately. However as stated you could use mono instead if this was a significant issue (that won't be an easy change to make).

My Mac is on 10.14, so 10.11 is quite old (Sept 2015). So we should really resolve this by targeting 10.12 runtime, so that the app won't try to run on unsupported OS versions.

@nopara73

This comment has been minimized.

Collaborator

nopara73 commented Nov 8, 2018

@danwalmsley You are right.

@nopara73

This comment has been minimized.

Collaborator

nopara73 commented Nov 8, 2018

@nopara73 nopara73 closed this Nov 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment