Skip to content


Subversion checkout URL

You can clone with
Download ZIP

Comparing changes

Choose two branches to see what’s changed or to start a new pull request. If you need to, you can also compare across forks.

Open a pull request

Create a new pull request by comparing changes across two branches. If you need to, you can also compare across forks.
This comparison is big! We’re only showing the most recent 250 commits
Commits on Apr 24, 2013
@Florin65 Florin65 gparted: version bumped to 0.16.0. 6f7c881
@Florin65 Florin65 clamav: version bumped to 0.97.8. e5161e8
@cavalier38 cavalier38 qemu: Version 1.4.1 bumped + texinfo patch 53edd6d
Commits on Apr 25, 2013
@v4hn v4hn zfs: _major_ cleanup/rewrite of the module
We support more than one hook file for a reason...

Also it's not acceptable to have more than one SOURCE_DIRECTORY.
Commits on Apr 26, 2013
@Florin65 Florin65 gstreamer: version bumped to 1.0.7. 7b20258
@Florin65 Florin65 gst-plugins-base-1.0: version bumped to 1.0.7. 2096877
@Florin65 Florin65 gst-plugins-bad-1.0: version bumped to 1.0.7. b0a454d
@Florin65 Florin65 gst-plugins-good-1.0: version bumped to 1.0.7. a8df02e
@Florin65 Florin65 nettle: version bumped to 2.7. e30a328
@Florin65 Florin65 telepathy-glib: version bumped to 0.20.2. bcdf09f
Commits on Apr 27, 2013
@Florin65 Florin65 snort: version bumped to 048f4d7
@Florin65 Florin65 squid: version bumped to 3.3.4. a2a8fbc
Commits on Apr 28, 2013
@Florin65 Florin65 git: version bumped to 4071364
@Florin65 Florin65 gdb: version bumped to 7.6. 752b325
@Florin65 Florin65 banshee: version bumped to 2.6.1. 3a149a2
@Florin65 Florin65 libzip: version bumped to 0.11.1. 779341a
@Florin65 Florin65 fribidi: versipn bumped to 0.19.5. 3de4a6f
@Florin65 Florin65 werzone2100: version bumped to 3.1.0. 47900ef
Commits on Apr 29, 2013
@Florin65 Florin65 gst-libav: an audio-video plugin for gstreamer 1.x c94e674
@Florin65 Florin65 libgee: version bumped to 0.10.1. c8565aa
@Florin65 Florin65 tcpdump: version bumped to 4.4.0. 4e866e9
@Florin65 Florin65 libmpdclient: version bumped to 2.8. cee4101
@v4hn v4hn inkscape: fix and simplify BUILD b220d0c
@Florin65 Florin65 lua: version bumped to 5.2.2. 7060d17
Commits on Apr 30, 2013
@Florin65 Florin65 Merge branch 'master' of 43bd24f
@Florin65 Florin65 samba: version bumped to 3.6.14. b67ec33
Commits on May 01, 2013
@Florin65 Florin65 gparted: version bumped to 0.16.1. c3e7f42
@Florin65 Florin65 logrotate: version bumped to 3.8.4. fb82f1f
@Florin65 Florin65 unrar: version bumped to 5.0.2. b5ae6cd
@Florin65 Florin65 mkvtoolnix: version bumped to 6.2.0. fccf044
@Ratler Ratler bc: Moved to core, required build dep by linux kernel e78554f
@Florin65 Florin65 mc: use the mirror url first. 3f2b83a
@v4hn v4hn lua: build shared object
Thank you to Rainbowcrypt for reporting
@v4hn v4hn lua: actually install so
... and provide pc file for modules like edje
@v4hn v4hn OpenImageIO-oiio: use TAGS, not branches... d7935f2
@v4hn v4hn OpenImageIO-oiio: erm... It's late... ae4afa2
Commits on May 02, 2013
@v4hn v4hn podofo: fix build with lua 5.2.2 3e23dc9
@Florin65 Florin65 libvirt: version bumped to 1.0.5. 22c7bb8
Jean-Michel Masereel lgi: version update + update the BUILD path for lua5.2 (otherwise awe…
…some fails to run)
Jean-Michel Masereel pypoppler: fix a bug that prevent pdfshuffler to load. 0cbb9d3
Christian Riggenbach NetAddr-IP: version bump to 4.068 a3b8d43
Commits on May 04, 2013
@Florin65 Florin65 phpMyAdmin: version bumped to 4.0.0. 136b24f
@Florin65 Florin65 mercurial: version bumped to 2.6. 51f2428
@v4hn v4hn multitail: version update 666a136
@v4hn v4hn coq: version update 2d84013
Commits on May 05, 2013
@v4hn v4hn wesnoth: fix build error c2e48a2
@v4hn v4hn tuxpaint: cleanup & patch for libpng1.6 fbe22d4
@v4hn v4hn devil: make it libpng16 compatible 32c231d
@v4hn v4hn lensfun: version update & build fix a94fea2
@v4hn v4hn texlive: add missing dependency
pdftex links against libpng
@Florin65 Florin65 cryptsetup: version bumped to 1.6.1. 3a3b42d
@v4hn v4hn lua: fix module path 1ede155
@v4hn v4hn lua: add missing symlink fd329dd
@v4hn v4hn enblend-enfuse: version update f4a03cb
@v4hn v4hn vigra: fix /usr/doc installation 31d6ed3
@v4hn v4hn fltk: add official download site d9f4ac1
@v4hn v4hn freedroidRPG: use internal lua
system lua is too new
@v4hn v4hn webkit: add missing dependency 7e47c3e
@v4hn v4hn t4k_common: make it work with modern libpng 94b221b
@v4hn v4hn plotutils: fix BUILD & compile with modern libpng 7cf6c0e
@v4hn v4hn VisualBoyAdvance: fix build with modern libpng 296f549
Commits on May 06, 2013
@v4hn v4hn compface: resurrected for sylpheed 781c398
@v4hn v4hn pilot-link: resurrected & fixed for sylpheed 8a0f0b8
@v4hn v4hn jpilot: resurrected for sylpheed bf49875
@v4hn v4hn sylpheed: resurrected & bumped
Happy Mailing wdp
@v4hn v4hn xchat: fix linking error 5bfcbbb
@v4hn v4hn cups: add proper mirror fd6b910
@v4hn v4hn FreeImage: fix bug & cleanup d15ad97
Commits on May 07, 2013
@Florin65 Florin65 MPlayer: version bumped to 1.1.1 7962332
stumbles lenfun: Changing source to gz and using SFORGE since this is where it…
… ends

up at anyway. Kept getting this from their bz2 file;

+ validating "/usr/src/lensfun-0.2.7"
+ creating building dir "/usr/src/lensfun-0.2.7"
+ Unpacking "/var/spool/lunar/lensfun-0.2.7.tar.bz2" in "/usr/src"
pbzip2: *ERROR during BZ2_bzDecompress - trailing garbage: ret=4; block=0; seq=3; isLastInSeq=1; avail_in=1732
Terminator thread: premature exit requested - quitting...
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
stumbles alsa-lib: Adding some patches to fix for example libkcompactdisc from…
… croaking on things like;

/usr/include/alsa/pcm.h:442:15: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'int'
 static inline int snd_pcm_abort(snd_pcm_t *pcm) { return snd_pcm_nonblock(pcm, 2); }

Anyway, may as well use the others from these fine folks.
@v4hn v4hn ufoai: fix build with gcc 4.8 b844bb3
stumbles avogadro: Version bump to 1.1.0. a606882
stumbles Merge branch 'master' of f8f00c7
Commits on May 08, 2013
stumbles texmaker: Version bump to 4.0.2. 1f621f9
stumbles imageworks-Field3D: Disabling docs. 36ce56e
@v4hn v4hn oolite: make it work with current libpng 9f342cd
Commits on May 09, 2013
stumbles getdata: Version bump to 0.8.3. 051d2e6
stumbles Merge branch 'master' of 0c1b9bb
@Florin65 Florin65 dirmngr: version bumped to 1.1.1. 73b2167
@Florin65 Florin65 gpgme: version bumped to 1.4.1. b26eba0
@Florin65 Florin65 gpgme: moved it from libs to crypto dir. d3926e6
@Florin65 Florin65 docbook-xml: remove the uneeded openjade and docbook-xsl depends.
The docbook-sgml depend is still questionable if needed indeed.
@Florin65 Florin65 pinentry: version bumped to 0.8.3. b46d6c9
@Florin65 Florin65 feh: version bumped to 2.9.2. 947447e
@Florin65 Florin65 freetyp2: version bumped to 2.4.12. 2ade65c
@Florin65 Florin65 libreoffice-bin: version bumped to 4.0.3. 646489a
@Florin65 Florin65 tomcat7-bin: version bumped to 7.0.40. a398909
@Florin65 Florin65 samba: version bumped to 3.6.15. 45d1278
@Florin65 Florin65 mono-zeroconf: remove it from the moonbase.
It was retired by it's devs.
Commits on May 10, 2013
@Florin65 Florin65 git: version bumped to 8ce4cf9
@Florin65 Florin65 ncdu: version bumped to 1.10. d8e39af
@Florin65 Florin65 gnupg: version bumped to 2.0.20. 59bd861
@Florin65 Florin65 gnutls: version bumped to 3.1.11. 269bc00
@Florin65 Florin65 ffmpeg: version bumped to 1.2.1. 63775cf
@Florin65 Florin65 giflib: version bumped to 4.2.1. 2b2851b
@Florin65 Florin65 numpy: version bumped to 1.7.1. 5c11915
Commits on May 11, 2013
@Ratler Ratler openafs, openafs-driver: Version bumped to 1.6.2
- Added patches for kernel 3.8 and kernel 3.9
@Ratler Ratler rabbitmq-server: Version bumped to 3.1.0 173672a
@Ratler Ratler mongodb: Version bumped to 2.4.3 ef12a6a
@Ratler Ratler virt-viewer: Version bumped to 0.5.6 69d292e
@Ratler Ratler virt-manager: Version bumped to 0.9.5 05a1bb7
@Ratler Ratler spice-gtk: Version bumped to 0.19 dc36126
@Ratler Ratler spice-protocol: Version bumped to 0.12.5 289a2fa
@v4hn v4hn harfbuzz: added to -other 203093f
@v4hn v4hn libgee06: add module to moonbase
This readds the old API of libgee still needed
by some modules. If you find a module which fails
to build with the more modern libgee, please fix
its dependency.
Commits on May 12, 2013
@Ratler Ratler virtinst: Version bumped to 0.600.4 46724a3
@Florin65 Florin65 zeitgeist: version bumped to 0.9.12. ff320bd
@Florin65 Florin65 libsigc++2: version bumped to 2.3.1. 075fe62
@Florin65 Florin65 librsvg: version bumped to 2.37.0. 73a4dc2
@Florin65 Florin65 gobject-introspection: version bumped to 1.36.0. 14d5c2d
@Florin65 Florin65 Revert "zeitgeist: version bumped to 0.9.12."
This reverts commit ff320bd.

zeitgeist: revert it.

It's not ready to bu bumped yet.
stumbles libwebp: Version bump to 0.3.0. c656abf
@Ratler Ratler gdbus-codegen: Version bumped to 2.36.1 8eaf0f4
stumbles Merge branch 'master' of 7325d8e
@Florin65 Florin65 atk: version bumped to 2.8.0. 1f7e079
@Florin65 Florin65 pango: version bumped to 1.34.0. 48da570
Commits on May 13, 2013
@v4hn v4hn freeglut: remove unneeded patch cfaf42f
stumbles colord: Version bump to 1.0.0 and adding a couple of optional_depends. 8e288f4
stumbles oxygen-gtk2: Version bump to 1.3.3. 38d45a4
@Florin65 Florin65 xboard: version bumped to 4.7.1. 00719d4
@Florin65 Florin65 Merge branch 'master' of 7765946
@Florin65 Florin65 whois: version bumped to 5.0.25. 8ad3f4a
@Florin65 Florin65 iw: version bumped to 3.10. 913889b
@Florin65 Florin65 liferea: version bumped to 1.8.13. 478016e
@Florin65 Florin65 Revert "xboard: version bumped to 4.7.1."
This reverts commit 00719d4.

revert it.
@Florin65 Florin65 xboard: version bumped to 4.7.1. f9e0df7
@Florin65 Florin65 gtk+-2: version bumped to 2.24.18. 032f888
stumbles pangox-compat: Adding to moonbase. e4eddc0
stumbles gtkglext: adding a depends. 80e031f
stumbles sun-jdk: Version bump to 7u21. 6821f15
stumbles sun-jdk: Forgot to bump UPDATED. ff5c3fc
Commits on May 14, 2013
stumbles live555: Version bump to 2013.04.30. d86ba1a
stumbles v4l-utils: Version bump to 0.9.5. 73cdacc
stumbles libopenraw: An adustment for those using turbo jpeg. e5e7119
stumbles tbb: Version bump to 41_20130314oss_src. 36895ac
stumbles opencv: Version bump to 2.4.5. ac630ff
stumbles wxMaxima: Version bump to 13.04.0. eed8aa5
stumbles R: Version bump to 2.15.3. 5a46325
stumbles postgis: Version bump to 2.0.3. 280702d
stumbles cfitsio: Version bump to 3340. 7035812
stumbles sbc: Version bump to 1.1. edfe5a3
stumbles lrzip: Version bump to 0.614. 405ea19
stumbles espeak: Version bump to 1.47.11. 0a09ac9
stumbles iso-codes: Version bump to 3.42. 0d202ae
stumbles libgphoto2: Version bump to 2.5.2. 989e294
stumbles gphoto2: Version bump to 2.5.2. ca36bf0
stumbles qpdf: Version bump to 4.1.0. 4663b34
stumbles blender: Version bump to 2.67. 606549b
Commits on May 15, 2013
@Florin65 Florin65 phpMyAdmin: version bumped to 4.0.1. 1179dd3
@Florin65 Florin65 thunderbird-bin: version bumped to 17.0.6. c0e1494
@Florin65 Florin65 firefox-bin: version bumped to 21.0. 6d171ee
Commits on May 16, 2013
stumbles flash-plugin-11: Version bump to 70d6384
stumbles ffmpeg: Just a minor BUILD tweak. 6045282
stumbles mupdf: Version bump to 1.2. 4846721
@Florin65 Florin65 mercurial: version bumped to 2.6.1. 42cdcca
@Florin65 Florin65 clutter: version bumped to 1.14.4. 061f603
@v4hn v4hn bitstream-vera: cleanup BUILD 38e281a
@v4hn v4hn cantarell-fonts: cleanup BUILD 5df6a58
@v4hn v4hn SourceCodePro-fonts: added to -other a94a0a9
stumbles xcm: Adding an optional_depends. ca0dd42
stumbles xcm: Adding a BUILD else it uses the wrong path for udev rules. d35d8f8
Commits on May 17, 2013
@v4hn v4hn gtkmathview: add pangox dependency 7f11276
stumbles audio: Fixing a typo. 4a36ee5
Commits on May 18, 2013
stumbles colord: Removing the option/selection to use root as the daemon user.…
… They do not

recommend this and is not required anymore of colord.
stumbles icc_examin: Version bump to 0.54. Using a patch from 8cd1c24
@v4hn v4hn dmenu: added to -other 19281c5
@v4hn v4hn firefox: updated to 21.0 4168fbc
@Florin65 Florin65 wireshark: version bumped to 1.8.7. 5b7487b
@Florin65 Florin65 midori: version bumped to 0.5.2. fd57aff
@v4hn v4hn libdatrie: move to -other
This is a pango dependency
@v4hn v4hn libthai: move to -other
This is a pango dependency
Commits on May 19, 2013
@v4hn v4hn nfs-utils: add optional_depends for krb5 & sqlite 7ac556c
Edward Tunnah xf86-input-evdev: added depends xorg-server. 850caba
Jean-Michel Masereel poppler: fix a problem with the cms option
to turn on/off the cms the syntax is (now) "--enable-cms=[auto|lcms1|lcms2|none]"
And the syntax in the DEPENDS file is "--enable-cms / --disable-cms" which both are treated as "--enable-cms=none" by the configure script.
This syntax breaks modules that need poppler to be compiled with cmsi (like cups-filters).
Jean-Michel Masereel cups-filters: new module
needed if we want to print docs other than .ps with cups
Jean-Michel Masereel cups: Add an optional depends for cups-filters 3fbf4e2
@v4hn v4hn cups-filters: moved to printer section 4870301
@v4hn v4hn fftw: remove this obsolete module
This is obsolete since 2009 and we finally
have no module left which requires this old API
@v4hn v4hn pulseaudio: cleanup 024d7dd
@v4hn v4hn libcanberra: remove obsolete GConf depends 39f11e9
@v4hn v4hn pavucontrol: update & fix dc34c5e
@v4hn v4hn pango: libthai is optional
... although not configurable
Commits on May 20, 2013
stumbles rdflib: Version bump to 4.0. You might want to do a lunar fix as this…
… version

eliminates all but two conflicting files with Python.
stumbles gajim: Removing invalid switch which removes the need for this BUILD. af5e680
@Florin65 Florin65 libburn: version bumped to 1.3.0. 830dc35
stumbles ZopeInterface: Adjusting the BUILD to the zope easy-install scripts do
not conflict.
@Florin65 Florin65 libisofs: version bumped to 1.3.0. abdc5b8
@Florin65 Florin65 libisoburn: version bumped to 1.3.0. ea3934d
@Florin65 Florin65 Merge branch 'master' of b861067
@Florin65 Florin65 cmake: version bumped to 2.8.11. 7af4a08
@v4hn v4hn vlc: fix build with lua 5.2.2 0ff4aef
Commits on May 21, 2013
Guillaume autossh: New module
Hi, here is a proposal for a new module.
Automatically restart SSH sessions and tunnels.

@v4hn v4hn autossh: moved to net/ section b9c6e8a
Commits on May 22, 2013
@Florin65 Florin65 sqlite: version bumped to 3.7.17. 4604870
@Florin65 Florin65 squid: version bumped to 3.3.5. 6b77083
@Florin65 Florin65 alsa-lib: version bumped to 3d60b73
@Florin65 Florin65 alsa-utils: version bumped to aa4802b
@v4hn v4hn poco: build with external libs 4e7371b
Commits on May 23, 2013
@Florin65 Florin65 doxygen: version bumped to 1.8.4. 250d361
stumbles ufraw: Adjusting the BUILD so ufraw version of dcraw does not conflic…
…t with

the dcraw module. Both are the same version, 9.17.
@Florin65 Florin65 dovecot: version bumped to 2.2.2. 6fac507
@Florin65 Florin65 weechat: version bumped to 0.4.1. e52ad1e
@Florin65 Florin65 calc: version bumped to 888066e
@Florin65 Florin65 Merge branch 'master' of 9990676
@Florin65 Florin65 iasl: version bumped to 20130517. 04b16df
Commits on May 24, 2013
stumbles orc: Version bump to 0.4.17. bf4fe5a
stumbles x264-snapshot: Version bump to 20130523-2245-stable. You will want to
recompile ffmpeg.
stumbles gst-ffmpeg: A little fix up here. Adding a BUILD so the patch will be…
… used and

switching to the gcc patch from the gentoo folks. Adding a CONFIGURE to allow
use of LGPL and adding an optional_depends for orc.
stumbles php5-suhosin: Adding aa patch from here;…

to fix the make tanking on our version of libxml2. Adjusting the POST_INSTALL, there is no php.ini-dist
using the production ini instead.
stumbles kdevelop-php-docs: Version bump t o 1.5.0. 160d462
@Florin65 Florin65 liferea: version bumped to 1.8.14. b035466
@Florin65 Florin65 harfbuzz: version bumped to 0.9.17. 9c52a3e
@Florin65 Florin65 mpg123: version bumped to 1.15.4. 3a9e7b6
@Florin65 Florin65 fping: version bumped to 3.5. 8390c0c
@Florin65 Florin65 apache-ant: version bumped to 1.9.1. 752a8e6
stumbles gcal: Version bump to 3.6.3. Adjusting the BUILD to fix regex typo an…
…d adding

a CONFIGURE to allow enabling of unicode and/or extended ASCII set.
stumbles Merge branch 'master' of b912c0f
stumbles chemical-mime-data: Adding to moonbase. Will be an optional_depends f…
…or kalzium.
stumbles netcdf: Version bump to 4.3.0. 57266f9
Commits on May 25, 2013
stumbles libblueray: Version bump to 0.3.0. be1d8e9
stumbles netcdf-cxx: Adding to moonbase. 0f0ceb1
stumbles matio: Adding to moonbase. 26926ef
@Florin65 Florin65 phpMyAdmin: version bumped to 4.0.2. abb86db
@Florin65 Florin65 git: version bumped to 1.8.3. fe93e87
@Florin65 Florin65 poppler: version bumped to 0.22.4. e40818c
@Florin65 Florin65 rfkill: version bumped to 0.5. 2afdb68
@Florin65 Florin65 gnome-desktop-sharp: small tweaks. 258e0a4
@Florin65 Florin65 boo: version bumped to 317a8ef
@Florin65 Florin65 mono: version bumped to 3.0.10. 7a553cb
@Florin65 Florin65 mod_perl: version bumped to 2.0.8. db7eff4
@Florin65 Florin65 dbus-python: it does not depend on Pyrex. ea3d369
stumbles inkscape: Adding a patch to fix a make failure. Taken from; 4760fc2
stumbles ntrack: Adding a patch from…

and adjusting the BUILD with some other twiddles.
stumbles speech-dispatcher: Version bump to 0.8. 614e8f1
Commits on May 26, 2013
stumbles openicc-data: Created a graphics/icc dir for any and all icc profiles…
… to reside.
stumbles basICColor_Offset_2009: Adding to moonbase. bfba72b
stumbles icc-profiles-openicc: Adding to moonbase. c1e8bd8
@Florin65 Florin65 speech-dispatcher: add a BUILD file in order to compile.
Without the BUILD file it demands for python > 3 version.
@Florin65 Florin65 Merge branch 'master' of a0a54e2
stumbles libcdio: Just fleshing out the DEPENDS. f34e2b2
stumbles vcdimager: Version bump to 0.7.24 and adjusting the DEPENDS. e67435e
stumbles aliases: Adding a %MPLAYER. e5cfa07
stumbles anki: Adjusting DEPENDS. e62564c
stumbles mplayer2: Got tired of playing whack-a-patch with the official release.
It would have amounted to a huge patch using current git. So instead
for now we will use a git version till they catch up with us.
Commits on May 27, 2013
stumbles tinyxml: Fixing a typo in the BUILD. ce28459
stumbles libmicrohttpd: Version bump to 0.9.27. 06e2b72
stumbles xbmc: Version bump to 12.2 with some changes to BUILD and DEPENDS. 585f57b
Terry Chan partclone: Version bump to 0.2.61 f1ddd6c
Zachary McGrew opal: version bump to 3.10.10 86dbc0f