Skip to content
Browse files

Packages: Update boost, geos, qwt, png

Not updating jpeg as it will break libtiff from OSGEO.
  • Loading branch information...
1 parent a961820 commit 0fb2369c78169688bbe1b3292d497ebf0da81af2 Zack Moratto committed Mar 24, 2013
Showing with 8 additions and 10 deletions.
  1. +8 −8 Packages.py
  2. +0 −2 build.py
View
16 Packages.py
@@ -397,9 +397,9 @@ def configure(self):
self.env['LDFLAGS'] = LDFLAGS_ORIG
class boost(Package):
- version = '1_52' # this is used in class liblas
+ version = '1_53' # this is used in class liblas
src = 'http://downloads.sourceforge.net/boost/boost_' + version + '_0.tar.bz2'
- chksum = 'cddd6b4526a09152ddc5db856463eaa1dc29c5d9'
+ chksum = 'e6dd1b62ceed0a51add3dda6f3fc3ce0f636a7f3'
patches = 'patches/boost'
def __init__(self, env):
@@ -467,8 +467,8 @@ class gsl(Package):
chksum = 'd914f84b39a5274b0a589d9b83a66f44cd17ca8e',
class geos(Package):
- src = 'http://download.osgeo.org/geos/geos-3.3.7.tar.bz2'
- chksum = 'd62c6f86ba854f319feaa5d957bebb8b6bed10a3'
+ src = 'http://download.osgeo.org/geos/geos-3.3.8.tar.bz2'
+ chksum = '1743e09f37eb75d85283a684a5765c4f44d035fa'
def configure(self):
super(geos, self).configure(disable=('python', 'ruby'))
@@ -552,8 +552,8 @@ def install(self):
super(qt, self).install()
class qwt(Package):
- src = 'http://downloads.sourceforge.net/qwt/qwt-6.0.1.tar.bz2',
- chksum = '301cca0c49c7efc14363b42e082b09056178973e',
+ src = 'http://downloads.sourceforge.net/qwt/qwt-6.0.2.tar.bz2',
+ chksum = 'cbdd00b29521987c9e7bc6aa51092f0474b9428d',
patches = 'patches/qwt'
def configure(self):
@@ -609,8 +609,8 @@ def configure(self):
super(jpeg, self).configure(enable=('shared',), disable=('static',))
class png(Package):
- src = 'http://downloads.sourceforge.net/libpng/libpng-1.5.13.tar.bz2'
- chksum = 'dfca34fa8281299a13cad87099f613ba639626e1'
+ src = 'http://downloads.sourceforge.net/libpng/libpng-1.5.14.tar.bz2'
+ chksum = 'b634cbd51698a3ddb495fa6decd074ae523c8fbf'
def configure(self):
super(png,self).configure(disable='static')
View
2 build.py
@@ -133,8 +133,6 @@ def summary(env):
if "llvm-gcc" in output:
die('Your compiler is an LLVM-GCC hybrid. It is our experience that these tools can not compile Vision Workbench and Stereo Pipeline correctly. Please change your compiler choice.')
elif 'clang' in e['CC']:
- # Remove this when Qt 4.8.4 comes out. Supposedly they have a fix ready.
- die('QT can\'t be built by Clang. Please chose a different compiler.')
output = output.lower()
keywords = output.split()
version_string = keywords[keywords.index('version')+1]

0 comments on commit 0fb2369

Please sign in to comment.
Something went wrong with that request. Please try again.