Permalink
Browse files

MacOS X: require SWIG 2.0.12

To fix build of modpython

(cherry picked from commit 591b95e)
  • Loading branch information...
1 parent bc4da23 commit 4f756da3dc5c133703b3a157f88f0bcf33b15eb7 @DarthGandalf DarthGandalf committed Feb 9, 2014
Showing with 6 additions and 1 deletion.
  1. +6 −1 configure.ac
View
@@ -390,7 +390,12 @@ fi
if test "x$PERL" != xno -o "x$PYTHON" != xno; then
old_USESWIG="$USESWIG"
if test "x$USESWIG" != "xno"; then
- AC_PROG_SWIG([2.0.8])
+ if test -z "$ISDARWIN"; then
+ AC_PROG_SWIG([2.0.8])
+ else
+ # Old SWIG doesn't like libc++, see https://github.com/swig/swig/issues/73
+ AC_PROG_SWIG([2.0.12])
+ fi
test -z "$SWIG" && USESWIG=no
if test "x$USESWIG" = xno -a "x$old_USESWIG" = yes; then
AC_MSG_ERROR([Could not found appropriate SWIG installation. Check config.log for details.])

0 comments on commit 4f756da

Please sign in to comment.