Skip to content

note dependency on automake for github install #200

Merged
merged 1 commit into from Sep 5, 2012

4 participants

@wchristian

No description provided.

@psychon
znc member
psychon commented Jul 24, 2012

What about autoconf, aclocal, pkg-config (for pkg.m4) etc? (I'm sure I forgot something)

@wchristian

I'm on Debian and all i needed to be able to compile it was apt-get automake. Noting this seems especially important to me, since aclocal is not a name that makes me think "gotta install automake" now, but is provided by that package.

@apmorton

automake depends on autoconf, which will generally itself depend on various other packages containing tools used in your autogen.sh
however, its best not to assume such dependencies exist. best explicitly list which tools it requires.

@wchristian

Feel free to do that then. :)

I don't know all the dependencies, i tried to install it from github, noticed that one was missing and offered a patch. Y'all can play "this is a neat patch, but it needs this trillion of bicycles before it's applied" all day long, but my involvement is done for now. Take it or leave it, or make it better. The choice is your's. :)

@DarthGandalf DarthGandalf merged commit c4f7290 into znc:master Sep 5, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.