Skip to content

`six` not installed by default #1

Closed
pferreir opened this Issue Feb 28, 2013 · 2 comments

2 participants

@pferreir

It looks like six is not being installed by default. Tests do not run properly.

pferreir /tmp/zope_index_test$ git clone 'git://github.com/zopefoundation/zope.index.git' src
pferreir /tmp/zope_index_test$ cd src/
pferreir /tmp/zope_index_test/src (master)$ source ../bin/activate
(zope_index_test)pferreir /tmp/zope_index_test/src (master)$ python setup.py install
(zope_index_test)pferreir /tmp/zope_index_test/src (master)$ python src/zope/index/tests.py 
Traceback (most recent call last):
  File "src/zope/index/tests.py", line 16, in <module>
    from unittest import TestCase, main, makeSuite
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/unittest/__init__.py", line 59, in <module>
    from .case import (TestCase, FunctionTestCase, SkipTest, skip, skipIf,
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/unittest/case.py", line 5, in <module>
    import difflib
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/difflib.py", line 36, in <module>
    from collections import namedtuple as _namedtuple
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/collections.py", line 10, in <module>
    from keyword import iskeyword as _iskeyword
  File "/private/tmp/zope_index_test/src/src/zope/index/keyword/__init__.py", line 1, in <module>
    from zope.index.keyword.index import KeywordIndex, CaseInsensitiveKeywordIndex
  File "/private/tmp/zope_index_test/lib/python2.7/site-packages/zope.index-4.0.1.dev0-py2.7-macosx-10.7-intel.egg/zope/index/keyword/__init__.py", line 1, in <module>
    from zope.index.keyword.index import KeywordIndex, CaseInsensitiveKeywordIndex
  File "/private/tmp/zope_index_test/lib/python2.7/site-packages/zope.index-4.0.1.dev0-py2.7-macosx-10.7-intel.egg/zope/index/keyword/index.py", line 17, in <module>
    import six
ImportError: No module named six```
@mgedmin
Zope Foundation member
mgedmin commented Feb 28, 2013

Fixed in 4.0.1.

@mgedmin mgedmin closed this Feb 28, 2013
@pferreir

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.