Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Improve error message for "zowe db2 call procedure" #22

Open
jthyssenrocket opened this issue Apr 29, 2019 · 3 comments

Comments

@jthyssenrocket
Copy link

commented Apr 29, 2019

zowe db2 call procedure "SYSPROC.ADMIN_INFO_SYSPARM(?)" --parameters "xxxx"
returns error message:
(empty array)

Suggestions:

  1. Improve documentation and built-in help to state that both input and output parameters should be passed, i.e., correct command is
    zowe db2 call procedure "SYSPROC.ADMIN_INFO_SYSPARM(?,?,?)" --parameters "xxxx" "xxxx" "xxxx"
  2. Improve error message instead of just showing empty array
@jelaplan

This comment has been minimized.

Copy link

commented Jun 25, 2019

What is the proposed error message? Sometimes we've include a proper example along with or in the error message and that can be more revealing than trying to explain what is missing.

@jthyssenrocket

This comment has been minimized.

Copy link
Author

commented Jun 25, 2019

I would suggest showing the SQLCA

@MikeBauerCA

This comment has been minimized.

Copy link

commented Jul 16, 2019

Recently, I helped others overcome an issue where they were receiving this error message. The root issue was that the wrong database name was specified in the profile. The (empty array) message was not very helpful in resolving the issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.